~ubuntu-branches/ubuntu/precise/empathy/precise-proposed-201205180810

« back to all changes in this revision

Viewing changes to debian/patches/00_lp_748535.patch

  • Committer: Bazaar Package Importer
  • Author(s): Brian Curtis, Brian Curtis, Ken VanDine
  • Date: 2011-06-01 10:35:24 UTC
  • mfrom: (1.1.70 upstream) (6.3.44 experimental)
  • Revision ID: james.westby@ubuntu.com-20110601103524-wx3wgp71394730jt
Tags: 3.1.1-1ubuntu1
[ Brian Curtis ]
* Merge with Debian experimental, remaining Ubuntu changes:
* debian/control:
  - Drop geoclue/mapping build-depends (they are in Universe)
  - Add Vcz-Bzr link
  - Add Suggests on telepathy-idle
  - Bump telepathy-butterfly, telepathy-haze to recommends
  - Don't recommend the freedesktop sound theme we have an ubuntu one
  - Add build depend for libunity-dev
* debian/rules:
  - Use autoreconf.mk
  - Disable map and location
* debian/empathy.install:
  - Install message indicator configuration
* debian/indicators/empathy:
  - Message indicator configuration
* debian/patches/01_lpi.patch:
  - Add Launchpad integration
* debian/patches/10_use_notify_osd_icons.patch:
  - Use the notify-osd image for new messages
* debian/patches/34_start_raised_execpt_in_session.patch
  - If not started with the session, we should always raise
* debian/patches/36_chat_window_default_size.patch:
  - Make the default chat window size larger
* debian/patches/37_facebook_default.patch:
  - Make facebook the default chat account type
* debian/patches/38_lp_569289.patch
  - Set freenode as default IRC network for new IRC accounts 
* debian/patches/41_unity_launcher_progress.patch
  - Display file transfer progress in the unity launcher

[ Ken VanDine ]
* debian/control
  - build depend on libgcr-3-dev instead of libgcr-dev
  - dropped build depends for libindicate, we will use telepathy-indicator
  - Depend on dconf-gsettings-backend | gsettings-backend
  - Added a Recommends for telepathy-indicator
* +debian/empathy.gsettings-override
  - Added an override for notifications-focus
* debian/patches/series
  - commented out 23_idomessagedialog_for_voip_and_ft.patch, until ido has 
    been ported to gtk3

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 73d8a18c6def748d78e91f0dda1145771c620b53 Mon Sep 17 00:00:00 2001
2
 
From: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
3
 
Date: Mon, 04 Apr 2011 08:23:53 +0000
4
 
Subject: event_manager_add: don't crash if approval is NULL (#646555)
5
 
 
6
 
When adding a "subscription request" event there is no EventManagerApproval
7
 
associated with the event.
8
 
---
9
 
diff --git a/src/empathy-event-manager.c b/src/empathy-event-manager.c
10
 
index 5b2174a..041d22a 100644
11
 
--- a/src/empathy-event-manager.c
12
 
+++ b/src/empathy-event-manager.c
13
 
@@ -233,7 +233,8 @@ event_manager_add (EmpathyEventManager *manager,
14
 
   event->public.header = g_strdup (header);
15
 
   event->public.message = g_strdup (message);
16
 
   event->public.must_ack = (func != NULL);
17
 
-  event->public.handler_instance = approval->handler_instance;
18
 
+  if (approval != NULL)
19
 
+    event->public.handler_instance = approval->handler_instance;
20
 
   event->inhibit = FALSE;
21
 
   event->func = func;
22
 
   event->user_data = user_data;
23
 
--
24
 
cgit v0.9
25