~ubuntu-branches/ubuntu/precise/empathy/precise-proposed-201205180810

« back to all changes in this revision

Viewing changes to debian/patches/70_append_messages_in_notifications.patch

  • Committer: Bazaar Package Importer
  • Author(s): Brian Curtis, Brian Curtis, Ken VanDine
  • Date: 2011-06-01 10:35:24 UTC
  • mfrom: (1.1.70 upstream) (6.3.44 experimental)
  • Revision ID: james.westby@ubuntu.com-20110601103524-wx3wgp71394730jt
Tags: 3.1.1-1ubuntu1
[ Brian Curtis ]
* Merge with Debian experimental, remaining Ubuntu changes:
* debian/control:
  - Drop geoclue/mapping build-depends (they are in Universe)
  - Add Vcz-Bzr link
  - Add Suggests on telepathy-idle
  - Bump telepathy-butterfly, telepathy-haze to recommends
  - Don't recommend the freedesktop sound theme we have an ubuntu one
  - Add build depend for libunity-dev
* debian/rules:
  - Use autoreconf.mk
  - Disable map and location
* debian/empathy.install:
  - Install message indicator configuration
* debian/indicators/empathy:
  - Message indicator configuration
* debian/patches/01_lpi.patch:
  - Add Launchpad integration
* debian/patches/10_use_notify_osd_icons.patch:
  - Use the notify-osd image for new messages
* debian/patches/34_start_raised_execpt_in_session.patch
  - If not started with the session, we should always raise
* debian/patches/36_chat_window_default_size.patch:
  - Make the default chat window size larger
* debian/patches/37_facebook_default.patch:
  - Make facebook the default chat account type
* debian/patches/38_lp_569289.patch
  - Set freenode as default IRC network for new IRC accounts 
* debian/patches/41_unity_launcher_progress.patch
  - Display file transfer progress in the unity launcher

[ Ken VanDine ]
* debian/control
  - build depend on libgcr-3-dev instead of libgcr-dev
  - dropped build depends for libindicate, we will use telepathy-indicator
  - Depend on dconf-gsettings-backend | gsettings-backend
  - Added a Recommends for telepathy-indicator
* +debian/empathy.gsettings-override
  - Added an override for notifications-focus
* debian/patches/series
  - commented out 23_idomessagedialog_for_voip_and_ft.patch, until ido has 
    been ported to gtk3

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Omer Akram <om26er@ubuntu.com>
2
 
Author: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
3
 
Subject: set a not empty string when setting EMPATHY_NOTIFY_MANAGER_CAP_X_CANONICAL_APPEND.
4
 
Origin: http://git.gnome.org/browse/empathy/commit/?h=gnome-2-34&id=554ea28a6a158f3dee384c485f84184cf606d61c
5
 
Bug: https://bugs.gnome.org/648842
6
 
Bug-Ubuntu: https://launchpad.net/bugs/769234
7
 
 
8
 
--- a//src/empathy-chat-window.c        2011-05-03 23:58:05.000000000 +0500
9
 
+++ b//src/empathy-chat-window.c        2011-05-03 23:56:40.163246021 +0500
10
 
@@ -1452,8 +1452,9 @@
11
 
                                  G_CALLBACK (chat_window_notification_closed_cb), window, 0);
12
 
 
13
 
                if (has_x_canonical_append) {
14
 
+                        /* We have to set a not empty string to keep libnotify happy */
15
 
                        notify_notification_set_hint_string (notification,
16
 
-                               EMPATHY_NOTIFY_MANAGER_CAP_X_CANONICAL_APPEND, "");
17
 
+                               EMPATHY_NOTIFY_MANAGER_CAP_X_CANONICAL_APPEND, "1");
18
 
                }
19
 
        }
20
 
 
21
 
diff -ruN a//src/empathy-status-icon.c b//src/empathy-status-icon.c
22
 
--- a//src/empathy-status-icon.c        2011-05-03 23:58:05.000000000 +0500
23
 
+++ b//src/empathy-status-icon.c        2011-05-03 23:57:31.015245996 +0500
24
 
@@ -268,8 +268,9 @@
25
 
                                                         NOTIFY_EXPIRES_DEFAULT);
26
 
 
27
 
                        if (has_x_canonical_append) {
28
 
+                                /* We have to set a not empty string to keep libnotify happy */
29
 
                                notify_notification_set_hint_string (notification,
30
 
-                                       EMPATHY_NOTIFY_MANAGER_CAP_X_CANONICAL_APPEND, "");
31
 
+                                       EMPATHY_NOTIFY_MANAGER_CAP_X_CANONICAL_APPEND, "1");
32
 
                        }
33
 
 
34
 
                        if (empathy_notify_manager_has_capability (priv->notify_mgr,