~canonical-dx-team/ubuntu/maverick/gtk+2.0/menuproxy

« back to all changes in this revision

Viewing changes to debian/patches/041_ia32-libs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2007-05-04 12:24:25 UTC
  • mfrom: (1.1.21 upstream)
  • Revision ID: james.westby@ubuntu.com-20070504122425-0m8midgzrp40y8w2
Tags: 2.10.12-1ubuntu1
* Sync with Debian
* New upstream version:
  Fixed bugs:
  - 379414 file chooser warnings when changing path in the entry
  - 418585 GtkFileChooserDefault sizing code is not DPI independent
  - 419568 Crash in search if start with special letter
  - 435062 build dies with icon cache validation
  - 379399 Segfault to call gtk_print_operation_run twice.
  - 387889 cups backend has problems when there are too many printers
  - 418531 invalid read to gtkicontheme.c gtk_icon_theme_lookup_icon...
  - 423916 crash in color scheme code
  - 424042 Segmentation fault while quickly pressing Alt+arrows
  - 415260 Protect against negative indices when setting values in G...
  - 419171 XGetVisualInfo() may not set nxvisuals
  - 128852 Gdk cursors don't look good on win32
  - 344657 Ctrl-H doesn't toggle "Show Hidden Files" setting
  - 345345 PrintOperation::paginate is not emitted for class handler
  - 347567 GtkPrintOperation::end-print is not emitted if it's cance...
  - 369112 gtk_ui_manager_add_ui should accept unnamed separator
  - 392015 Selected menu item invisible on Windows Vista
  - 399253 MS-Windows Theme Bottom Tab placement rendering glitches
  - 399425 gtk_input_dialog_fill_axes() adds child to gtkscrolledwin...
  - 403251 [patch] little memory leak in GtkPrintJob
  - 403267 [patch] memory leak in GtkPageSetupUnixDialog
  - 403470 MS-Windows Theme tab placement other than on top leaks a ...
  - 404506 Windows system fonts that have multi-byte font names cann...
  - 405089 Incorrect window placement for GtkEventBox private window
  - 405515 Minor leak in gtkfilesystemmodel.c
  - 405539 gdk_pixbuf_save() for PNG saver can return FALSE without ...
  - 415681 gdk_window_clear_area includes an extra line and column o...
  - 418219 GtkRecentChooser should apply filter before sorting and c...
  - 418403 Scroll to printer after selecting it from settings
  - 421985 _gtk_print_operation_platform_backend_launch_preview
  - 421990 gtk_print_job_get_surface
  - 421993 gtk_print_operation_init
  - 423064 Conditional jump or move depends on uninitialised value(s...
  - 423722 Fix printing header in gtk-demo
  - 424168 gtk_print_operation_run on async preview
  - 425655 Don't install gtk+-unix-print-2.0.pc on non-UNIX platforms
  - 425786 GDK segfaults if XineramaQueryScreens fails
  - 428665 Lpr Backend gets stuck in infinite loop during gtk_enumer...
  - 429902 GtkPrintOperation leaks cairo contextes
  - 431997 First delay of GdkPixbufAnimationIter is wrong
  - 433242 Inconsistent scroll arrow position calculations
  - 433972 Placing gtk.Expander inside a gtk.TextView() changes gtk....
  - 434261 _gtk_toolbar_elide_underscores incorrectly handles some s...
  - 383354 ctrl-L should make 'Location' entry disappear
  - 418673 gtk_recent_manager_add_item
  - 429732 gtk_accel_group_finalize accesses invalid memory
  - 435028 WM_CLIENT_LEADER is wrong on the leader_window
  - 431067 Background of the header window is not updated
  - 338843 add recent files support inside the ui manager
  - 148535 add drop shadow to menus, tooltips, etc. under Windows XP
* debian/control.in:
  - Conflicts on ubuntulooks (<= 0.9.11-1)
* debian/patches/15_default-fallback-icon-theme.patch:
  - patch from Debian, fallback on gnome icon theme

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: gtk+2.0-2.10.11/gdk-pixbuf/gdk-pixbuf-io.c
 
2
===================================================================
 
3
--- gtk+2.0-2.10.11.orig/gdk-pixbuf/gdk-pixbuf-io.c     2007-04-13 10:56:36.000000000 +0200
 
4
+++ gtk+2.0-2.10.11/gdk-pixbuf/gdk-pixbuf-io.c  2007-04-13 10:56:40.000000000 +0200
 
5
@@ -280,8 +280,20 @@
 
6
   gchar *result = g_strdup (g_getenv ("GDK_PIXBUF_MODULE_FILE"));
 
7
 
 
8
   if (!result)
 
9
-         result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gdk-pixbuf.loaders", NULL);
 
10
-
 
11
+    {
 
12
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
 
13
+# if defined (__i386__)
 
14
+      result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gdk-pixbuf.loaders.32", NULL);
 
15
+# else
 
16
+      result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gdk-pixbuf.loaders.64", NULL);
 
17
+#endif
 
18
+      /* Prefer compat gdk-pixbuf.loaders file if it's usable. */
 
19
+      if (g_file_test(result, G_FILE_TEST_EXISTS))
 
20
+        return result;
 
21
+      g_free (result);
 
22
+#endif
 
23
+      result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gdk-pixbuf.loaders", NULL);
 
24
+    }
 
25
   return result;
 
26
 }
 
27
 
 
28
Index: gtk+2.0-2.10.11/gtk/gtkrc.c
 
29
===================================================================
 
30
--- gtk+2.0-2.10.11.orig/gtk/gtkrc.c    2007-04-13 10:56:36.000000000 +0200
 
31
+++ gtk+2.0-2.10.11/gtk/gtkrc.c 2007-04-13 10:56:40.000000000 +0200
 
32
@@ -447,7 +447,20 @@
 
33
       if (im_module_file)
 
34
        result = g_strdup (im_module_file);
 
35
       else
 
36
-       result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtk.immodules", NULL);
 
37
+        {
 
38
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
 
39
+# if defined (__i386__)
 
40
+         result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtk.immodules.32", NULL);
 
41
+# else
 
42
+         result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtk.immodules.64", NULL);
 
43
+# endif
 
44
+          /* Prefer compat gtk.immodules file if it's usable. */
 
45
+          if (g_file_test(result, G_FILE_TEST_EXISTS))
 
46
+            return result;
 
47
+          g_free (result);
 
48
+#endif
 
49
+          result = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtk.immodules", NULL);
 
50
+        }
 
51
     }
 
52
 
 
53
   return result;
 
54
@@ -519,7 +532,21 @@
 
55
   else
 
56
     {
 
57
       const gchar *home;
 
58
-      str = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtkrc", NULL);
 
59
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
 
60
+# if defined (__i386__)
 
61
+      str = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtkrc.32", NULL);
 
62
+# else
 
63
+      str = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtkrc.64", NULL);
 
64
+# endif
 
65
+      /* Prefer compat gtkrc if it's usable. */
 
66
+      if (!g_file_test(str, G_FILE_TEST_EXISTS))
 
67
+        {
 
68
+          g_free (str), /* continue in next line */
 
69
+#endif
 
70
+          str = g_build_filename (GTK_SYSCONFDIR, "gtk-2.0", "gtkrc", NULL);
 
71
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
 
72
+        }
 
73
+#endif
 
74
 
 
75
       gtk_rc_add_default_file (str);
 
76
       g_free (str);
 
77
@@ -527,7 +554,21 @@
 
78
       home = g_get_home_dir ();
 
79
       if (home)
 
80
        {
 
81
-         str = g_build_filename (home, ".gtkrc-2.0", NULL);
 
82
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
 
83
+# if defined (__i386__)
 
84
+          str = g_build_filename (home, ".gtkrc-2.0.32", NULL);
 
85
+# else
 
86
+          str = g_build_filename (home, ".gtkrc-2.0.64", NULL);
 
87
+# endif
 
88
+          /* Prefer compat .gtkrc-2.0 if it's usable. */
 
89
+          if (!g_file_test(str, G_FILE_TEST_EXISTS))
 
90
+            {
 
91
+              g_free (str), /* continue in next line */
 
92
+#endif
 
93
+              str = g_build_filename (home, ".gtkrc-2.0", NULL);
 
94
+#if defined(__linux__) && ( defined(__i386__) || defined (__x86_64__) || defined(__ia64__) )
 
95
+            }
 
96
+#endif
 
97
          gtk_rc_add_default_file (str);
 
98
          g_free (str);
 
99
        }