~timo-jyrinki/ubuntu/trusty/pitivi/backport_utopic_fixes

« back to all changes in this revision

Viewing changes to debian/patches/01_disable-devel-mode.patch

  • Committer: Package Import Robot
  • Author(s): Sebastian Dröge
  • Date: 2014-04-05 15:28:16 UTC
  • mfrom: (6.1.13 sid)
  • Revision ID: package-import@ubuntu.com-20140405152816-6lijoax4cngiz5j5
Tags: 0.93-3
* debian/control:
  + Depend on python-gi (>= 3.10), older versions do not work
    with pitivi (Closes: #732813).
  + Add missing dependency on gir1.2-clutter-gst-2.0 (Closes: #743692).
  + Add suggests on gir1.2-notify-0.7 and gir1.2-gnomedesktop-3.0.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: pitivi/bin/pitivi.in
2
2
===================================================================
3
 
--- pitivi.orig/bin/pitivi.in   2011-09-28 18:57:27.773150417 +0200
4
 
+++ pitivi/bin/pitivi.in        2011-09-28 18:57:42.765224752 +0200
5
 
@@ -38,13 +38,6 @@
6
 
 # Add the path of pitivi stuff
7
 
 # TODO : change it when it's finally in cvs
8
 
 
9
 
-def _get_root_dir():
10
 
-    return '/'.join(os.path.dirname(os.path.abspath(__file__)).split('/')[:-1])
11
 
-
12
 
-def _in_devel():
13
 
-    rd = _get_root_dir()
14
 
-    return os.path.exists(os.path.join(rd, '.git'))
15
 
-
16
 
 def _prepend_env_path(name, value):
17
 
     os.environ[name] = os.pathsep.join(value +
18
 
             os.environ.get(name, "").split(os.pathsep))
19
 
@@ -56,13 +49,8 @@
 
3
--- pitivi.orig/bin/pitivi.in   2014-03-29 15:24:00.782574262 +0100
 
4
+++ pitivi/bin/pitivi.in        2014-03-29 15:24:00.778574243 +0100
 
5
@@ -46,8 +46,7 @@
 
6
 
 
7
 # Check if we're in development or installed version and set paths properly
 
8
 def _in_devel():
 
9
-    root_dir = os.path.dirname(os.path.dirname(os.path.abspath(__file__)))
 
10
-    return os.path.exists(os.path.join(root_dir, '.git'))
 
11
+    return False
 
12
 
 
13
 
20
14
 def _add_pitivi_path():
21
 
     global localedir
22
 
     dir = os.path.dirname(os.path.abspath(__file__))
23
 
-    root = None
24
 
-    if _in_devel():
25
 
-        root = os.path.split(dir)[0]
26
 
-        localedir = os.path.join(os.path.split(dir)[0], 'locale')
27
 
-    else:
28
 
-        root = os.path.join(LIBDIR, 'pitivi', 'python')
29
 
-        localedir = "@DATADIR@/locale"
30
 
+    root = os.path.join(LIBDIR, 'pitivi', 'python')
31
 
+    localedir = "@DATADIR@/locale"
32
 
 
33
 
     if not root in sys.path:
34
 
         sys.path.insert(0, root)
 
15
Index: pitivi/pitivi/configure.py
 
16
===================================================================
 
17
--- pitivi.orig/pitivi/configure.py     2014-03-29 15:24:00.782574262 +0100
 
18
+++ pitivi/pitivi/configure.py  2014-03-29 15:24:38.154750476 +0100
 
19
@@ -26,17 +26,8 @@
 
20
 import os.path
 
21
 
 
22
 
 
23
-# Again, mostly the same thing as in bin/pitivi.in and pitivi/utils/misc.py:
 
24
-def _get_root_dir():
 
25
-    return '/'.join(os.path.dirname(os.path.abspath(__file__)).split('/')[:-1])
 
26
-
 
27
-
 
28
-def in_devel():
 
29
-    """
 
30
-    Returns whether the app is run from a git checkout.
 
31
-    """
 
32
-    rd = _get_root_dir()
 
33
-    return os.path.exists(os.path.join(rd, '.git'))
 
34
+def in_devel():
 
35
+    return False
 
36
 
 
37
 
 
38
 LIBDIR = '/usr/local/lib'
 
39
Index: pitivi/pitivi/configure.py.in
 
40
===================================================================
 
41
--- pitivi.orig/pitivi/configure.py.in  2014-03-29 15:24:00.782574262 +0100
 
42
+++ pitivi/pitivi/configure.py.in       2014-03-29 15:24:50.862810463 +0100
 
43
@@ -26,18 +26,8 @@
 
44
 import os.path
 
45
 
 
46
 
 
47
-# Again, mostly the same thing as in bin/pitivi.in and pitivi/utils/misc.py:
 
48
-def _get_root_dir():
 
49
-    return '/'.join(os.path.dirname(os.path.abspath(__file__)).split('/')[:-1])
 
50
-
 
51
-
 
52
-def in_devel():
 
53
-    """
 
54
-    Returns whether the app is run from a git checkout.
 
55
-    """
 
56
-    rd = _get_root_dir()
 
57
-    return os.path.exists(os.path.join(rd, '.git'))
 
58
-
 
59
+def in_devel():
 
60
+    return False
 
61
 
 
62
 LIBDIR = '@LIBDIR@'
 
63
 PKGDATADIR = '@DATADIR@/@PACKAGE@'