~ubuntu-branches/ubuntu/precise/boinc/precise

« back to all changes in this revision

Viewing changes to debian/patches/flops_not_found.patch

Tags: 6.12.8+dfsg-1
* New upstream release.
* Simplified debian/rules

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: boinc/sched/sched_customize.cpp
 
2
===================================================================
 
3
--- boinc.orig/sched/sched_customize.cpp        2010-12-05 16:39:02.000000000 +0100
 
4
+++ boinc/sched/sched_customize.cpp     2010-12-05 16:42:57.000000000 +0100
 
5
@@ -108,7 +108,7 @@
 
6
             return PLAN_REJECT_ATI_NO_DEVICE;
 
7
         }
 
8
 
 
9
-        hu.flops = cp->flops();
 
10
+        hu.flops = cp->peak_flops();
 
11
 
 
12
         // assume we'll need 0.5% as many CPU FLOPS as GPU FLOPS
 
13
         // to keep the GPU fed.
 
14
@@ -187,7 +187,7 @@
 
15
             }
 
16
             return PLAN_REJECT_CUDA_MEM;
 
17
         }
 
18
-        hu.flops = cp->flops_estimate();
 
19
+        hu.flops = cp->peak_flops();
 
20
         if (!strcmp(plan_class, "cuda23")) {
 
21
             hu.flops *= 1.01;
 
22
         }