~kroq-gar78/ubuntu/precise/gnome-control-center/fix-885947

« back to all changes in this revision

Viewing changes to debian/patches/06_use_icon_description_in_indicator.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rodrigo Moya
  • Date: 2011-05-17 10:47:27 UTC
  • mfrom: (0.1.11 experimental) (1.1.45 upstream)
  • Revision ID: james.westby@ubuntu.com-20110517104727-lqel6m8vhfw5jby1
Tags: 1:3.0.1.1-1ubuntu1
* Rebase on Debian, remaining Ubuntu changes:
* debian/control:
  - Build-Depend on hardening-wrapper, dpkg-dev and dh-autoreconf
  - Add dependency on ubuntu-system-service
  - Remove dependency on gnome-icon-theme-symbolic
  - Move dependency on apg, gnome-icon-theme-symbolic and accountsservice to
    be a Recommends: until we get them in main
* debian/rules:
  - Use autoreconf
  - Add binary-post-install rule for gnome-control-center-data
  - Run dh-autoreconf
* debian/gnome-control-center.dirs:
* debian/gnome-control-center.links:
  - Add a link to the control center shell for indicators
* debian/patches/00_disable-nm.patch:
  - Temporary patch to disable building with NetworkManager until we get
    the new one in the archive
* debian/patches/01_git_remove_gettext_calls.patch:
  - Remove calls to AM_GNU_GETTEXT, IT_PROG_INTLTOOL should be enough
* debian/patches/01_git_kill_warning.patch:
  - Kill warning
* debian/patches/50_ubuntu_systemwide_prefs.patch:
  - Ubuntu specific proxy preferences
* debian/patches/51_ubuntu_system_keyboard.patch:
  - Implement the global keyboard spec at https://wiki.ubuntu.com/DefaultKeyboardSettings

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/typing-break/drwright.c b/typing-break/drwright.c
2
 
index 5e8674d..c7fc026 100644
3
 
--- a/typing-break/drwright.c
4
 
+++ b/typing-break/drwright.c
5
 
@@ -521,6 +521,8 @@ update_status (DrWright *dr)
6
 
 #ifdef HAVE_APP_INDICATOR
7
 
        item = gtk_ui_manager_get_widget (dr->ui_manager, "/Pop/TakeABreak");
8
 
        gtk_menu_item_set_label (GTK_MENU_ITEM (item), str);
9
 
+       app_indicator_set_attention_icon_full (dr->indicator, TYPING_MONITOR_ATTENTION_ICON, str);
10
 
+       app_indicator_set_icon_full (dr->indicator, TYPING_MONITOR_ACTIVE_ICON, str);
11
 
 #else
12
 
        gtk_status_icon_set_tooltip_text (dr->icon, str);
13
 
 #endif /* HAVE_APP_INDICATOR */