~ubuntu-branches/debian/sid/lammps/sid

« back to all changes in this revision

Viewing changes to debian/patches/set_configure_flags.patch

  • Committer: Package Import Robot
  • Author(s): Anton Gladky
  • Date: 2015-04-29 23:44:49 UTC
  • mfrom: (5.1.3 experimental)
  • Revision ID: package-import@ubuntu.com-20150429234449-mbhy9utku6hp6oq8
Tags: 0~20150313.gitfa668e1-1
Upload into unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: use CXX and LD-flags, proposed by build environment instead
2
 
 of hardcoded. Fix linkage problem with fftw3.
3
 
Author: Anton Gladky <gladk@debian.org>
4
 
Last-Update: 2014-02-13
5
 
 
6
 
--- a/src/MAKE/Makefile.openmpi
7
 
+++ b/src/MAKE/Makefile.openmpi
8
 
@@ -7,14 +7,13 @@
9
 
 # specify flags and libraries needed for your compiler
10
 
 
11
 
 CC =           mpic++
12
 
-CCFLAGS =      -O2 \
13
 
-               -funroll-loops -fstrict-aliasing -Wall -W -Wno-uninitialized
14
 
+CCFLAGS =      -Wall $(shell dpkg-buildflags --get CXXFLAGS) -fopenmp
15
 
 SHFLAGS =      -fPIC
16
 
 DEPFLAGS =     -M
17
 
 
18
 
 LINK =         mpic++
19
 
-LINKFLAGS =    -O
20
 
-LIB =           -lstdc++
21
 
+LINKFLAGS =    -O $(shell dpkg-buildflags --get LDFLAGS)
22
 
+LIB =           -lstdc++ -fopenmp
23
 
 SIZE =         size
24
 
 
25
 
 ARCHIVE =      ar
26
 
@@ -29,7 +28,7 @@
27
 
 # LAMMPS ifdef settings, OPTIONAL
28
 
 # see possible settings in doc/Section_start.html#2_2 (step 4)
29
 
 
30
 
-LMP_INC =      -DLAMMPS_GZIP
31
 
+LMP_INC =      -DLAMMPS_GZIP -DLAMMPS_JPEG
32
 
 
33
 
 # MPI library, REQUIRED
34
 
 # see discussion in doc/Section_start.html#2_2 (step 5)
35
 
@@ -49,9 +48,9 @@
36
 
 # PATH = path for FFT library
37
 
 # LIB = name of FFT library
38
 
 
39
 
-FFT_INC =       -DFFT_FFTW
40
 
+FFT_INC =       -DFFT_FFTW3
41
 
 FFT_PATH = 
42
 
-FFT_LIB =      -lfftw
43
 
+FFT_LIB =      -lfftw3
44
 
 
45
 
 # JPEG and/or PNG library, OPTIONAL
46
 
 # see discussion in doc/Section_start.html#2_2 (step 7)
47
 
@@ -62,7 +61,7 @@
48
 
 
49
 
 JPG_INC =       
50
 
 JPG_PATH =     
51
 
-JPG_LIB =      
52
 
+JPG_LIB =      -ljpeg
53
 
 
54
 
 # ---------------------------------------------------------------------
55
 
 # build rules and dependencies