~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/arm64/0011-hw-arm-virt-Support-cpu-host.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 3ded9f1c71d346ddf64c6cb3e376625e76ce04c9 Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Fri, 22 Nov 2013 17:17:18 +0000
4
 
Subject: [PATCH 11/49] hw/arm/virt: Support -cpu host
5
 
 
6
 
Support -cpu host in virt machine (treating it like an A15, ie
7
 
with a GIC v2 and the A15's private peripherals.)
8
 
 
9
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
10
 
Reviewed-by: Christoffer Dall <christoffer.dall@linaro.org>
11
 
Message-id: 1385140638-10444-12-git-send-email-peter.maydell@linaro.org
12
 
---
13
 
 hw/arm/virt.c | 8 ++++++++
14
 
 1 file changed, 8 insertions(+)
15
 
 
16
 
diff --git a/hw/arm/virt.c b/hw/arm/virt.c
17
 
index 1e42cc2..9531b5a 100644
18
 
--- a/hw/arm/virt.c
19
 
+++ b/hw/arm/virt.c
20
 
@@ -122,6 +122,14 @@ static VirtBoardInfo machines[] = {
21
 
         .memmap = a15memmap,
22
 
         .irqmap = a15irqmap,
23
 
     },
24
 
+    {
25
 
+        .cpu_model = "host",
26
 
+        /* We use the A15 private peripheral model to get a V2 GIC */
27
 
+        .qdevname = "a15mpcore_priv",
28
 
+        .gic_compatible = "arm,cortex-a15-gic",
29
 
+        .memmap = a15memmap,
30
 
+        .irqmap = a15irqmap,
31
 
+    },
32
 
 };
33
 
 
34
 
 static VirtBoardInfo *find_machine_info(const char *cpu)
35
 
1.8.5.2
36