~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0062-hw-omap_intc.c-Don-t-complain-about-nonexistent-regi.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 9ed345079d30adb7bd5964e91eb9542f6514c8de Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:34 +0000
 
4
Subject: [PATCH 62/70] hw/omap_intc.c: Don't complain about nonexistent
 
5
 register read by Linux
 
6
 
 
7
The Linux omap kernel now deliberately reads from the nonexistent register
 
8
at 0xf8, which only exists on ti816x, because it knows that on omap2 and
 
9
omap3 this will read as zero. Handle it that way (ie suppress qemu's
 
10
complaint about read of a bad register), since otherwise the omap3
 
11
model has so many warnings it is unusable.
 
12
 
 
13
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
14
---
 
15
 hw/intc/omap_intc.c | 6 +++++-
 
16
 1 file changed, 5 insertions(+), 1 deletion(-)
 
17
 
 
18
diff --git a/hw/intc/omap_intc.c b/hw/intc/omap_intc.c
 
19
index 7dd63da..6cbb259 100644
 
20
--- a/hw/intc/omap_intc.c
 
21
+++ b/hw/intc/omap_intc.c
 
22
@@ -414,7 +414,11 @@ static uint64_t omap2_inth_read(void *opaque, hwaddr addr,
 
23
             offset &= ~0x60;
 
24
             bank = &s->bank[bank_no];
 
25
         } else {
 
26
-            OMAP_BAD_REG(addr);
 
27
+            /* Linux reads the nonexistent interrupt status register at 0xf8
 
28
+             * every time through its interrupt handler, so don't actually
 
29
+             * warn about it because it swamps the console with output.
 
30
+             */
 
31
+            /* OMAP_BAD_REG(addr); */
 
32
             return 0;
 
33
         }
 
34
     }
 
35
-- 
 
36
1.8.5.2
 
37