~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/arm64/0028-target-arm-A64-add-stubs-for-a64-specific-helpers.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 52089f8f64beb4536e00ef0218423dd78a3b72a0 Mon Sep 17 00:00:00 2001
2
 
From: Alexander Graf <agraf@suse.de>
3
 
Date: Tue, 17 Dec 2013 19:42:32 +0000
4
 
Subject: [PATCH 28/49] target-arm: A64: add stubs for a64 specific helpers
5
 
 
6
 
We will need helpers that only make sense with AArch64. Add
7
 
helper-a64.{c,h} files as stubs that we can fill with these
8
 
helpers in the following patches.
9
 
 
10
 
Signed-off-by: Alexander Graf <agraf@suse.de>
11
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
12
 
Reviewed-by: Richard Henderson <rth@twiddle.net>
13
 
 
14
 
Conflicts:
15
 
        target-arm/Makefile.objs
16
 
        target-arm/helper.h
17
 
---
18
 
 target-arm/Makefile.objs |  2 +-
19
 
 target-arm/helper-a64.c  | 25 +++++++++++++++++++++++++
20
 
 target-arm/helper-a64.h  | 18 ++++++++++++++++++
21
 
 target-arm/helper.h      |  4 ++++
22
 
 4 files changed, 48 insertions(+), 1 deletion(-)
23
 
 create mode 100644 target-arm/helper-a64.c
24
 
 create mode 100644 target-arm/helper-a64.h
25
 
 
26
 
diff --git a/target-arm/Makefile.objs b/target-arm/Makefile.objs
27
 
index bc23563..df6d972 100644
28
 
--- a/target-arm/Makefile.objs
29
 
+++ b/target-arm/Makefile.objs
30
 
@@ -7,4 +7,4 @@ obj-$(call lnot,$(CONFIG_KVM)) += kvm-stub.o
31
 
 obj-y += translate.o op_helper.o helper.o cpu.o
32
 
 obj-y += neon_helper.o iwmmxt_helper.o
33
 
 obj-y += gdbstub.o
34
 
-obj-$(TARGET_AARCH64) += cpu64.o translate-a64.o gdbstub64.o
35
 
+obj-$(TARGET_AARCH64) += cpu64.o translate-a64.o helper-a64.o gdbstub64.o
36
 
diff --git a/target-arm/helper-a64.c b/target-arm/helper-a64.c
37
 
new file mode 100644
38
 
index 0000000..adb8428
39
 
--- /dev/null
40
 
+++ b/target-arm/helper-a64.c
41
 
@@ -0,0 +1,25 @@
42
 
+/*
43
 
+ *  AArch64 specific helpers
44
 
+ *
45
 
+ *  Copyright (c) 2013 Alexander Graf <agraf@suse.de>
46
 
+ *
47
 
+ * This library is free software; you can redistribute it and/or
48
 
+ * modify it under the terms of the GNU Lesser General Public
49
 
+ * License as published by the Free Software Foundation; either
50
 
+ * version 2 of the License, or (at your option) any later version.
51
 
+ *
52
 
+ * This library is distributed in the hope that it will be useful,
53
 
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
54
 
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
55
 
+ * Lesser General Public License for more details.
56
 
+ *
57
 
+ * You should have received a copy of the GNU Lesser General Public
58
 
+ * License along with this library; if not, see <http://www.gnu.org/licenses/>.
59
 
+ */
60
 
+
61
 
+#include "cpu.h"
62
 
+#include "exec/gdbstub.h"
63
 
+#include "helper.h"
64
 
+#include "qemu/host-utils.h"
65
 
+#include "sysemu/sysemu.h"
66
 
+#include "qemu/bitops.h"
67
 
diff --git a/target-arm/helper-a64.h b/target-arm/helper-a64.h
68
 
new file mode 100644
69
 
index 0000000..dd28306
70
 
--- /dev/null
71
 
+++ b/target-arm/helper-a64.h
72
 
@@ -0,0 +1,18 @@
73
 
+/*
74
 
+ *  AArch64 specific helper definitions
75
 
+ *
76
 
+ *  Copyright (c) 2013 Alexander Graf <agraf@suse.de>
77
 
+ *
78
 
+ * This library is free software; you can redistribute it and/or
79
 
+ * modify it under the terms of the GNU Lesser General Public
80
 
+ * License as published by the Free Software Foundation; either
81
 
+ * version 2 of the License, or (at your option) any later version.
82
 
+ *
83
 
+ * This library is distributed in the hope that it will be useful,
84
 
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
85
 
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
86
 
+ * Lesser General Public License for more details.
87
 
+ *
88
 
+ * You should have received a copy of the GNU Lesser General Public
89
 
+ * License along with this library; if not, see <http://www.gnu.org/licenses/>.
90
 
+ */
91
 
diff --git a/target-arm/helper.h b/target-arm/helper.h
92
 
index d459a39..643e28e 100644
93
 
--- a/target-arm/helper.h
94
 
+++ b/target-arm/helper.h
95
 
@@ -463,4 +463,8 @@ DEF_HELPER_3(neon_qzip8, void, env, i32, i32)
96
 
 DEF_HELPER_3(neon_qzip16, void, env, i32, i32)
97
 
 DEF_HELPER_3(neon_qzip32, void, env, i32, i32)
98
 
 
99
 
+#ifdef TARGET_AARCH64
100
 
+#include "helper-a64.h"
101
 
+#endif
102
 
+
103
 
 #include "exec/def-helper.h"
104
 
1.8.5.2
105