~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0038-omap_uart-Add-revision-property.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From e38d989581bf7ec09ae9f6647e522e077b994a7a Mon Sep 17 00:00:00 2001
 
2
From: Jan Vesely <jano.vesely@gmail.com>
 
3
Date: Mon, 18 Feb 2013 16:58:30 +0000
 
4
Subject: [PATCH 38/70] omap_uart: Add revision property.
 
5
 
 
6
Set revision to values reported by beagleboard(-xm) hw.
 
7
 
 
8
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
 
9
---
 
10
 hw/char/omap_uart.c | 4 +++-
 
11
 1 file changed, 3 insertions(+), 1 deletion(-)
 
12
 
 
13
diff --git a/hw/char/omap_uart.c b/hw/char/omap_uart.c
 
14
index 55982fa..c2cf46a 100644
 
15
--- a/hw/char/omap_uart.c
 
16
+++ b/hw/char/omap_uart.c
 
17
@@ -48,6 +48,7 @@ typedef struct omap_uart_s {
 
18
     const MemoryRegionOps *serial_ops;
 
19
     uint32_t mmio_size;
 
20
     uint32_t baudrate;
 
21
+    uint32_t revision;
 
22
     qemu_irq tx_drq;
 
23
     qemu_irq rx_drq;
 
24
 
 
25
@@ -167,7 +168,7 @@ static uint64_t omap_uart_read(void *opaque, hwaddr addr,
 
26
     case 0x4C: /* OSC_12M_SEL (OMAP1) */
 
27
         return s->clksel;
 
28
     case 0x50: /* MVR */
 
29
-        return 0x30;
 
30
+        return s->revision;
 
31
     case 0x54: /* SYSC (OMAP2) */
 
32
         return s->syscontrol;
 
33
     case 0x58: /* SYSS (OMAP2) */
 
34
@@ -330,6 +331,7 @@ static int omap_uart_init(SysBusDevice *busdev)
 
35
 }
 
36
 
 
37
 static Property omap_uart_properties[] = {
 
38
+    DEFINE_PROP_UINT32("revision", struct omap_uart_s, revision, 0x30),
 
39
     DEFINE_PROP_UINT32("mmio_size", struct omap_uart_s, mmio_size, 0x400),
 
40
     DEFINE_PROP_UINT32("baudrate", struct omap_uart_s, baudrate, 0),
 
41
     DEFINE_PROP_CHR("chardev", struct omap_uart_s, chr),
 
42
-- 
 
43
1.8.5.2
 
44