~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro/0010-omap_gptimer-Add-omap_gp_timer_change_clk.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From cb5fbe17dacaf5f6ac03cce23e207e6fd8fc42bd Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:24 +0000
4
 
Subject: [PATCH 10/70] omap_gptimer: Add omap_gp_timer_change_clk()
5
 
 
6
 
Add omap_gp_timer_change_clk() functions to inform the gptimer code when
7
 
the clock source for a timer has been changed.
8
 
 
9
 
TODO: is this the best way to do this??
10
 
---
11
 
 hw/timer/omap_gptimer.c | 6 ++++++
12
 
 include/hw/arm/omap.h   | 1 +
13
 
 2 files changed, 7 insertions(+)
14
 
 
15
 
diff --git a/hw/timer/omap_gptimer.c b/hw/timer/omap_gptimer.c
16
 
index 259f5c4..769a8e5 100644
17
 
--- a/hw/timer/omap_gptimer.c
18
 
+++ b/hw/timer/omap_gptimer.c
19
 
@@ -75,6 +75,12 @@ struct omap_gp_timer_s {
20
 
 #define GPT_OVF_IT     (1 << 1)
21
 
 #define GPT_MAT_IT     (1 << 0)
22
 
 
23
 
+/*if the clock source of gptimer changes, rate must be regenerated*/
24
 
+void omap_gp_timer_change_clk(struct omap_gp_timer_s *timer)
25
 
+{
26
 
+    timer->rate = omap_clk_getrate(timer->clk);
27
 
+}
28
 
+
29
 
 static inline void omap_gp_timer_intr(struct omap_gp_timer_s *timer, int it)
30
 
 {
31
 
     if (timer->it_ena & it) {
32
 
diff --git a/include/hw/arm/omap.h b/include/hw/arm/omap.h
33
 
index 086692f..5e9d41d 100644
34
 
--- a/include/hw/arm/omap.h
35
 
+++ b/include/hw/arm/omap.h
36
 
@@ -844,6 +844,7 @@ struct omap_gp_timer_s;
37
 
 struct omap_gp_timer_s *omap_gp_timer_init(struct omap_target_agent_s *ta,
38
 
                 qemu_irq irq, omap_clk fclk, omap_clk iclk);
39
 
 void omap_gp_timer_reset(struct omap_gp_timer_s *s);
40
 
+void omap_gp_timer_change_clk(struct omap_gp_timer_s *timer);
41
 
 
42
 
 /* OMAP2 sysctimer */
43
 
 struct omap_synctimer_s;
44
 
1.8.5.2
45