~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro/0023-omap_i2c-add-support-for-underflowing.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From db4c3d78b6dd75259990030056ea343f19e1f46e Mon Sep 17 00:00:00 2001
2
 
From: Riku Voipio <riku.voipio@nokia.com>
3
 
Date: Mon, 18 Feb 2013 16:58:27 +0000
4
 
Subject: [PATCH 23/70] omap_i2c: add support for underflowing
5
 
 
6
 
kernel workaround for OMAP3430 Errata 1.153 requires this..
7
 
---
8
 
 hw/i2c/omap_i2c.c | 5 ++++-
9
 
 1 file changed, 4 insertions(+), 1 deletion(-)
10
 
 
11
 
diff --git a/hw/i2c/omap_i2c.c b/hw/i2c/omap_i2c.c
12
 
index f048635..93e85d4 100644
13
 
--- a/hw/i2c/omap_i2c.c
14
 
+++ b/hw/i2c/omap_i2c.c
15
 
@@ -200,7 +200,10 @@ static uint32_t omap_i2c_read(void *opaque, hwaddr addr)
16
 
         return s->mask;
17
 
 
18
 
     case 0x08: /* I2C_STAT */
19
 
-        return s->stat | (i2c_bus_busy(s->bus) << 12);
20
 
+        ret = s->stat | (i2c_bus_busy(s->bus) << 12 );
21
 
+        if (s->revision >= OMAP3_INTR_REV && (s->stat & 0x4010)) /* XRDY or XDR  */
22
 
+            s->stat |= 1 << 10; /* XUDF as required by errata 1.153 */
23
 
+        return ret;
24
 
 
25
 
     case 0x0c: /* I2C_IV / I2C_WE */
26
 
         if (s->revision >= OMAP3_INTR_REV)
27
 
1.8.5.2
28