~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/expose-vmx_qemu64cpu.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Expose VMX cpuid feature to the default "qemu64" CPU type,
 
2
 supporting Intel compatible VMX nested virtualization.
 
3
Author: Dave Walker (Daviey) <DaveWalker@ubuntu.com>
 
4
 
 
5
Index: qemu/target-i386/cpu.c
 
6
===================================================================
 
7
--- qemu.orig/target-i386/cpu.c 2013-05-22 21:14:59.021657270 +0200
 
8
+++ qemu/target-i386/cpu.c      2013-05-22 21:51:52.342963476 +0200
 
9
@@ -441,7 +441,8 @@
 
10
             CPUID_MTRR | CPUID_CLFLUSH | CPUID_MCA |
 
11
             CPUID_PSE36,
 
12
         .features[FEAT_1_ECX] =
 
13
-            CPUID_EXT_SSE3 | CPUID_EXT_CX16 | CPUID_EXT_POPCNT,
 
14
+            CPUID_EXT_SSE3 | CPUID_EXT_CX16 | CPUID_EXT_POPCNT |
 
15
+            CPUID_EXT_VMX,
 
16
         .features[FEAT_8000_0001_EDX] =
 
17
             (PPRO_FEATURES & CPUID_EXT2_AMD_ALIASES) |
 
18
             CPUID_EXT2_LM | CPUID_EXT2_SYSCALL | CPUID_EXT2_NX,