~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0052-hw-nseries.c-Force-pointer-visibility-on-n8x0.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 5bf94c0d4d044ce5355a1b58c47d67ce3eb69f5a Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:32 +0000
 
4
Subject: [PATCH 52/70] hw/nseries.c: Force pointer visibility on n8x0
 
5
 
 
6
---
 
7
 hw/arm/nseries.c | 1 +
 
8
 1 file changed, 1 insertion(+)
 
9
 
 
10
diff --git a/hw/arm/nseries.c b/hw/arm/nseries.c
 
11
index da7a759..9a2bd74 100644
 
12
--- a/hw/arm/nseries.c
 
13
+++ b/hw/arm/nseries.c
 
14
@@ -1471,6 +1471,7 @@ static void n8x0_init(QEMUMachineInitArgs *args,
 
15
         n810_tsc_setup(s);
 
16
         n810_kbd_setup(s);
 
17
     }
 
18
+    cursor_hide = 0; // who wants to use touchscreen without a pointer?
 
19
     n8x0_spi_setup(s);
 
20
     n8x0_dss_setup(s);
 
21
     n8x0_cbus_setup(s);
 
22
-- 
 
23
1.8.5.2
 
24