~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro/0039-fifo8-Add-support-for-reading-number-of-bytes-in-FIF.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 1cd0587fee5aee4cdc45607b4547be39a3b99583 Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 5 Aug 2013 16:13:01 +0100
4
 
Subject: [PATCH 39/70] fifo8: Add support for reading number of bytes in FIFO
5
 
 
6
 
Add a fifo8_num() function which returns the number
7
 
of bytes currently in the FIFO.
8
 
 
9
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
10
 
---
11
 
 include/qemu/fifo8.h | 10 ++++++++++
12
 
 util/fifo8.c         |  5 +++++
13
 
 2 files changed, 15 insertions(+)
14
 
 
15
 
diff --git a/include/qemu/fifo8.h b/include/qemu/fifo8.h
16
 
index d318f71..fec175c 100644
17
 
--- a/include/qemu/fifo8.h
18
 
+++ b/include/qemu/fifo8.h
19
 
@@ -86,6 +86,16 @@ bool fifo8_is_empty(Fifo8 *fifo);
20
 
 
21
 
 bool fifo8_is_full(Fifo8 *fifo);
22
 
 
23
 
+/**
24
 
+ * fifo8_num:
25
 
+ * @fifo: FIFO to check
26
 
+ *
27
 
+ * Return the number of bytes of data currently in the FIFO.
28
 
+ *
29
 
+ * Returns: number of bytes of data in FIFO.
30
 
+ */
31
 
+uint32_t fifo8_num(Fifo8 *fifo);
32
 
+
33
 
 extern const VMStateDescription vmstate_fifo8;
34
 
 
35
 
 #define VMSTATE_FIFO8(_field, _state) {                              \
36
 
diff --git a/util/fifo8.c b/util/fifo8.c
37
 
index 013e903..75f0f3b 100644
38
 
--- a/util/fifo8.c
39
 
+++ b/util/fifo8.c
40
 
@@ -65,6 +65,11 @@ bool fifo8_is_full(Fifo8 *fifo)
41
 
     return (fifo->num == fifo->capacity);
42
 
 }
43
 
 
44
 
+uint32_t fifo8_num(Fifo8 *fifo)
45
 
+{
46
 
+    return fifo->num;
47
 
+}
48
 
+
49
 
 const VMStateDescription vmstate_fifo8 = {
50
 
     .name = "Fifo8",
51
 
     .version_id = 1,
52
 
1.8.5.2
53