~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro/0065-musb-add-dummy-support-for-ulpi-pass-through-registe.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 9d28df700df975ba280dd26c217d52da65f6803e Mon Sep 17 00:00:00 2001
2
 
From: =?UTF-8?q?Juha=20Riihim=C3=A4ki?= <juha.riihimaki@nokia.com>
3
 
Date: Mon, 18 Feb 2013 16:58:35 +0000
4
 
Subject: [PATCH 65/70] musb: add dummy support for ulpi pass-through registers
5
 
MIME-Version: 1.0
6
 
Content-Type: text/plain; charset=UTF-8
7
 
Content-Transfer-Encoding: 8bit
8
 
 
9
 
Signed-off-by: Juha Riihimäki <juha.riihimaki@nokia.com>
10
 
---
11
 
 hw/usb/hcd-musb.c | 18 ++++++++++++++++++
12
 
 1 file changed, 18 insertions(+)
13
 
 
14
 
diff --git a/hw/usb/hcd-musb.c b/hw/usb/hcd-musb.c
15
 
index 66bc61a..888850d 100644
16
 
--- a/hw/usb/hcd-musb.c
17
 
+++ b/hw/usb/hcd-musb.c
18
 
@@ -65,6 +65,7 @@
19
 
 #define MUSB_HDRC_ULPI_REGDATA 0x74
20
 
 #define MUSB_HDRC_ULPI_REGADDR 0x75
21
 
 #define MUSB_HDRC_ULPI_REGCTL  0x76
22
 
+#define MUSB_HDRC_ULPI_RAWDATA  0x77
23
 
 
24
 
 /* Extended config & PHY control */
25
 
 #define MUSB_HDRC_ENDCOUNT     0x78    /* 8 bit */
26
 
@@ -1293,6 +1294,16 @@ static uint32_t musb_readb(void *opaque, hwaddr addr)
27
 
         ep = ((addr - MUSB_HDRC_FIFO) >> 2) & 0xf;
28
 
         return musb_read_fifo(s->ep + ep);
29
 
 
30
 
+    case MUSB_HDRC_ULPI_REGADDR:
31
 
+    case MUSB_HDRC_ULPI_REGDATA:
32
 
+    case MUSB_HDRC_ULPI_RAWDATA:
33
 
+        /* TODO */
34
 
+        return 0x00;
35
 
+
36
 
+    case MUSB_HDRC_ULPI_REGCTL:
37
 
+        /* TODO */
38
 
+        return 0x02;
39
 
+
40
 
     default:
41
 
         TRACE("unknown register 0x%02x", (int) addr);
42
 
         return 0x00;
43
 
@@ -1380,6 +1391,13 @@ static void musb_writeb(void *opaque, hwaddr addr, uint32_t value)
44
 
         musb_write_fifo(s->ep + ep, value & 0xff);
45
 
         break;
46
 
 
47
 
+    case MUSB_HDRC_ULPI_REGADDR:
48
 
+    case MUSB_HDRC_ULPI_REGCTL:
49
 
+    case MUSB_HDRC_ULPI_REGDATA:
50
 
+    case MUSB_HDRC_ULPI_RAWDATA:
51
 
+        /* TODO */
52
 
+        break;
53
 
+
54
 
     default:
55
 
         TRACE("unknown register 0x%02x", (int) addr);
56
 
         break;
57
 
1.8.5.2
58