~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0063-hw-omap_gpio.c-Don-t-complain-about-some-writes-to-r.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From ed1a241ec7302f0fd83834b941b22306a98ec5da Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:34 +0000
 
4
Subject: [PATCH 63/70] hw/omap_gpio.c: Don't complain about some writes to r/o
 
5
 registers
 
6
 
 
7
Don't complain about some writes to r/o OMAP2 GPIO registers, because the
 
8
kernel will do them anyway.
 
9
 
 
10
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
11
---
 
12
 hw/gpio/omap_gpio.c | 4 ++--
 
13
 1 file changed, 2 insertions(+), 2 deletions(-)
 
14
 
 
15
diff --git a/hw/gpio/omap_gpio.c b/hw/gpio/omap_gpio.c
 
16
index b8f572b..e1d9a2b 100644
 
17
--- a/hw/gpio/omap_gpio.c
 
18
+++ b/hw/gpio/omap_gpio.c
 
19
@@ -393,7 +393,7 @@ static void omap2_gpio_module_write(void *opaque, hwaddr addr,
 
20
     case 0x00: /* GPIO_REVISION */
 
21
     case 0x14: /* GPIO_SYSSTATUS */
 
22
     case 0x38: /* GPIO_DATAIN */
 
23
-        OMAP_RO_REG(addr);
 
24
+        /* read-only, ignore quietly */
 
25
         break;
 
26
 
 
27
     case 0x10: /* GPIO_SYSCONFIG */
 
28
@@ -539,7 +539,7 @@ static void omap2_gpio_module_writep(void *opaque, hwaddr addr,
 
29
     case 0x00: /* GPIO_REVISION */
 
30
     case 0x14: /* GPIO_SYSSTATUS */
 
31
     case 0x38: /* GPIO_DATAIN */
 
32
-        OMAP_RO_REG(addr);
 
33
+        /* read-only, ignore quietly */
 
34
         break;
 
35
 
 
36
     case 0x10: /* GPIO_SYSCONFIG */
 
37
-- 
 
38
1.8.5.2
 
39