~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0016-omap_i2c-clean-up-revision-numbers.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From b800580dbe280c17fefe098c44cdca14d56ec28c Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:26 +0000
 
4
Subject: [PATCH 16/70] omap_i2c: clean up revision numbers
 
5
 
 
6
---
 
7
 hw/i2c/omap_i2c.c | 9 ++++++---
 
8
 1 file changed, 6 insertions(+), 3 deletions(-)
 
9
 
 
10
diff --git a/hw/i2c/omap_i2c.c b/hw/i2c/omap_i2c.c
 
11
index f528b2b..7d47dc7 100644
 
12
--- a/hw/i2c/omap_i2c.c
 
13
+++ b/hw/i2c/omap_i2c.c
 
14
@@ -51,8 +51,11 @@ typedef struct OMAPI2CState {
 
15
     uint16_t test;
 
16
 } OMAPI2CState;
 
17
 
 
18
-#define OMAP2_INTR_REV 0x34
 
19
-#define OMAP2_GC_REV   0x34
 
20
+/* I2C controller revision register values */
 
21
+#define OMAP1_INTR_REV    0x11
 
22
+#define OMAP2_INTR_REV    0x34
 
23
+#define OMAP3_INTR_REV    0x3c
 
24
+#define OMAP3630_INTR_REV 0x40
 
25
 
 
26
 static void omap_i2c_interrupts_update(OMAPI2CState *s)
 
27
 {
 
28
@@ -266,7 +269,7 @@ static void omap_i2c_write(void *opaque, hwaddr addr,
 
29
         return;
 
30
 
 
31
     case 0x04: /* I2C_IE */
 
32
-        s->mask = value & (s->revision < OMAP2_GC_REV ? 0x1f : 0x3f);
 
33
+        s->mask = value & (s->revision < OMAP2_INTR_REV ? 0x1f : 0x3f);
 
34
         break;
 
35
 
 
36
     case 0x08: /* I2C_STAT */
 
37
-- 
 
38
1.8.5.2
 
39