~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/0015-target-arm-Implement-ARMv8-SIMD-VMAXNM-and-VMINNM-in.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From af0a1192fc770c6d6921d83fab897cc561c9b3c9 Mon Sep 17 00:00:00 2001
 
2
From: Will Newton <will.newton@linaro.org>
 
3
Date: Fri, 6 Dec 2013 17:01:42 +0000
 
4
Subject: [PATCH 15/49] target-arm: Implement ARMv8 SIMD VMAXNM and VMINNM
 
5
 instructions.
 
6
 
 
7
This adds support for the ARMv8 Advanced SIMD VMAXNM and VMINNM
 
8
instructions.
 
9
 
 
10
Signed-off-by: Will Newton <will.newton@linaro.org>
 
11
Message-id: 1386158099-9239-7-git-send-email-will.newton@linaro.org
 
12
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
13
---
 
14
 target-arm/translate.c | 31 ++++++++++++++++++++++---------
 
15
 1 file changed, 22 insertions(+), 9 deletions(-)
 
16
 
 
17
diff --git a/target-arm/translate.c b/target-arm/translate.c
 
18
index 9a8069e..73ed266 100644
 
19
--- a/target-arm/translate.c
 
20
+++ b/target-arm/translate.c
 
21
@@ -4553,7 +4553,7 @@ static void gen_neon_narrow_op(int op, int u, int size,
 
22
 #define NEON_3R_FLOAT_CMP 28 /* float VCEQ, VCGE, VCGT */
 
23
 #define NEON_3R_FLOAT_ACMP 29 /* float VACGE, VACGT, VACLE, VACLT */
 
24
 #define NEON_3R_FLOAT_MINMAX 30 /* float VMIN, VMAX */
 
25
-#define NEON_3R_VRECPS_VRSQRTS 31 /* float VRECPS, VRSQRTS */
 
26
+#define NEON_3R_FLOAT_MISC 31 /* float VRECPS, VRSQRTS, VMAXNM/MINNM */
 
27
 
 
28
 static const uint8_t neon_3r_sizes[] = {
 
29
     [NEON_3R_VHADD] = 0x7,
 
30
@@ -4586,7 +4586,7 @@ static const uint8_t neon_3r_sizes[] = {
 
31
     [NEON_3R_FLOAT_CMP] = 0x5, /* size bit 1 encodes op */
 
32
     [NEON_3R_FLOAT_ACMP] = 0x5, /* size bit 1 encodes op */
 
33
     [NEON_3R_FLOAT_MINMAX] = 0x5, /* size bit 1 encodes op */
 
34
-    [NEON_3R_VRECPS_VRSQRTS] = 0x5, /* size bit 1 encodes op */
 
35
+    [NEON_3R_FLOAT_MISC] = 0x5, /* size bit 1 encodes op */
 
36
 };
 
37
 
 
38
 /* Symbolic constants for op fields for Neon 2-register miscellaneous.
 
39
@@ -4847,8 +4847,9 @@ static int disas_neon_data_insn(CPUARMState * env, DisasContext *s, uint32_t ins
 
40
                 return 1;
 
41
             }
 
42
             break;
 
43
-        case NEON_3R_VRECPS_VRSQRTS:
 
44
-            if (u) {
 
45
+        case NEON_3R_FLOAT_MISC:
 
46
+            /* VMAXNM/VMINNM in ARMv8 */
 
47
+            if (u && !arm_feature(env, ARM_FEATURE_V8)) {
 
48
                 return 1;
 
49
             }
 
50
             break;
 
51
@@ -5137,11 +5138,23 @@ static int disas_neon_data_insn(CPUARMState * env, DisasContext *s, uint32_t ins
 
52
             tcg_temp_free_ptr(fpstatus);
 
53
             break;
 
54
         }
 
55
-        case NEON_3R_VRECPS_VRSQRTS:
 
56
-            if (size == 0)
 
57
-                gen_helper_recps_f32(tmp, tmp, tmp2, cpu_env);
 
58
-            else
 
59
-                gen_helper_rsqrts_f32(tmp, tmp, tmp2, cpu_env);
 
60
+        case NEON_3R_FLOAT_MISC:
 
61
+            if (u) {
 
62
+                /* VMAXNM/VMINNM */
 
63
+                TCGv_ptr fpstatus = get_fpstatus_ptr(1);
 
64
+                if (size == 0) {
 
65
+                    gen_helper_vfp_maxnms(tmp, tmp, tmp2, fpstatus);
 
66
+                } else {
 
67
+                    gen_helper_vfp_minnms(tmp, tmp, tmp2, fpstatus);
 
68
+                }
 
69
+                tcg_temp_free_ptr(fpstatus);
 
70
+            } else {
 
71
+                if (size == 0) {
 
72
+                    gen_helper_recps_f32(tmp, tmp, tmp2, cpu_env);
 
73
+                } else {
 
74
+                    gen_helper_rsqrts_f32(tmp, tmp, tmp2, cpu_env);
 
75
+              }
 
76
+            }
 
77
             break;
 
78
         case NEON_3R_VFM:
 
79
         {
 
80
-- 
 
81
1.8.5.2
 
82