~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro/0030-hw-omap_spi.c-Fix-indentation-following-previous-pat.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 6d35c920e91a43398a70939acb8fda47e7bff95b Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:28 +0000
4
 
Subject: [PATCH 30/70] hw/omap_spi.c: Fix indentation following previous patch
5
 
 
6
 
Fix indentation (whitespace-only change split out from previous
7
 
patch to make it easier to review).
8
 
 
9
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
10
 
---
11
 
 hw/ssi/omap_spi.c | 70 +++++++++++++++++++++++++++----------------------------
12
 
 1 file changed, 35 insertions(+), 35 deletions(-)
13
 
 
14
 
diff --git a/hw/ssi/omap_spi.c b/hw/ssi/omap_spi.c
15
 
index 3a6e01b..30392ac 100644
16
 
--- a/hw/ssi/omap_spi.c
17
 
+++ b/hw/ssi/omap_spi.c
18
 
@@ -183,50 +183,50 @@ static void omap_mcspi_transfer_run(OMAPSPIBusState *s, int chnum)
19
 
 
20
 
     if (!(s->control & 1) ||        /* SINGLE */
21
 
         (ch->config & (1 << 20))) { /* FORCE */
22
 
-            wl = 1 + (0x1f & (ch->config >> 7)); /* WL */
23
 
-            if (!IS_OMAP3_SPI(s) || s->fifo_ch != chnum ||
24
 
-                !((ch->config >> 27) & 3)) {     /* FFER | FFEW */
25
 
+        wl = 1 + (0x1f & (ch->config >> 7)); /* WL */
26
 
+        if (!IS_OMAP3_SPI(s) || s->fifo_ch != chnum ||
27
 
+            !((ch->config >> 27) & 3)) {     /* FFER | FFEW */
28
 
+            ch->rx = spi_txrx(s->bus, chnum, ch->tx, wl);
29
 
+        } else {
30
 
+            switch ((ch->config >> 27) & 3) {
31
 
+            case 1: /* !FFER, FFEW */
32
 
+                if (trm != 1)
33
 
+                    ch->tx = omap_mcspi_fifo_get(&s->tx_fifo, wl);
34
 
                 ch->rx = spi_txrx(s->bus, chnum, ch->tx, wl);
35
 
-            } else {
36
 
-                switch ((ch->config >> 27) & 3) {
37
 
-                case 1: /* !FFER, FFEW */
38
 
+                s->fifo_wcnt--;
39
 
+                break;
40
 
+            case 2: /* FFER, !FFEW */
41
 
+                ch->rx = spi_txrx(s->bus, chnum, ch->tx, wl);
42
 
+                if (trm != 2)
43
 
+                    omap_mcspi_fifo_put(&s->rx_fifo, wl, ch->rx);
44
 
+                s->fifo_wcnt--;
45
 
+                break;
46
 
+            case 3: /* FFER, FFEW */
47
 
+                while (s->rx_fifo.len < s->rx_fifo.size &&
48
 
+                       s->tx_fifo.len && s->fifo_wcnt) {
49
 
                     if (trm != 1)
50
 
                         ch->tx = omap_mcspi_fifo_get(&s->tx_fifo, wl);
51
 
                     ch->rx = spi_txrx(s->bus, chnum, ch->tx, wl);
52
 
-                    s->fifo_wcnt--;
53
 
-                    break;
54
 
-                case 2: /* FFER, !FFEW */
55
 
-                    ch->rx = spi_txrx(s->bus, chnum, ch->tx, wl);
56
 
                     if (trm != 2)
57
 
                         omap_mcspi_fifo_put(&s->rx_fifo, wl, ch->rx);
58
 
                     s->fifo_wcnt--;
59
 
-                    break;
60
 
-                case 3: /* FFER, FFEW */
61
 
-                    while (s->rx_fifo.len < s->rx_fifo.size &&
62
 
-                           s->tx_fifo.len && s->fifo_wcnt) {
63
 
-                        if (trm != 1)
64
 
-                            ch->tx = omap_mcspi_fifo_get(&s->tx_fifo, wl);
65
 
-                        ch->rx = spi_txrx(s->bus, chnum, ch->tx, wl);
66
 
-                        if (trm != 2)
67
 
-                            omap_mcspi_fifo_put(&s->rx_fifo, wl, ch->rx);
68
 
-                        s->fifo_wcnt--;
69
 
-                    }
70
 
-                    break;
71
 
-                default:
72
 
-                    break;
73
 
                 }
74
 
-                if ((ch->config & (1 << 28)) &&        /* FFER */
75
 
-                    s->rx_fifo.len >= s->rx_fifo.size)
76
 
-                    ch->status |= 1 << 6;              /* RXFFF */
77
 
-                ch->status &= ~(1 << 5);               /* RXFFE */
78
 
-                ch->status &= ~(1 << 4);               /* TXFFF */
79
 
-                if ((ch->config & (1 << 27)) &&        /* FFEW */
80
 
-                    !s->tx_fifo.len)
81
 
-                    ch->status |= 1 << 3;              /* TXFFE */
82
 
-                if (!s->fifo_wcnt &&
83
 
-                    ((s->xferlevel >> 16) & 0xffff))   /* WCNT */
84
 
-                    s->irqst |= 1 << 17;               /* EOW */
85
 
+                break;
86
 
+            default:
87
 
+                break;
88
 
             }
89
 
+            if ((ch->config & (1 << 28)) &&        /* FFER */
90
 
+                s->rx_fifo.len >= s->rx_fifo.size)
91
 
+                ch->status |= 1 << 6;              /* RXFFF */
92
 
+            ch->status &= ~(1 << 5);               /* RXFFE */
93
 
+            ch->status &= ~(1 << 4);               /* TXFFF */
94
 
+            if ((ch->config & (1 << 27)) &&        /* FFEW */
95
 
+                !s->tx_fifo.len)
96
 
+                ch->status |= 1 << 3;              /* TXFFE */
97
 
+            if (!s->fifo_wcnt &&
98
 
+                ((s->xferlevel >> 16) & 0xffff))   /* WCNT */
99
 
+                s->irqst |= 1 << 17;               /* EOW */
100
 
+        }
101
 
     }
102
 
 
103
 
     ch->tx = 0;
104
 
1.8.5.2
105