~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro/0047-dsi-generate-complexio-ulps0-irq-when-asserting-lane.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 106e5bb76bbe6a4d7909042b1251973a1bcae462 Mon Sep 17 00:00:00 2001
2
 
From: =?UTF-8?q?Juha=20Riihim=C3=A4ki?= <juha.riihimaki@nokia.com>
3
 
Date: Mon, 18 Feb 2013 16:58:31 +0000
4
 
Subject: [PATCH 47/70] dsi: generate complexio ulps0 irq when asserting lane
5
 
 sig2
6
 
MIME-Version: 1.0
7
 
Content-Type: text/plain; charset=UTF-8
8
 
Content-Transfer-Encoding: 8bit
9
 
 
10
 
Signed-off-by: Juha Riihimäki <juha.riihimaki@nokia.com>
11
 
---
12
 
 hw/display/omap_dss.c | 5 +++++
13
 
 1 file changed, 5 insertions(+)
14
 
 
15
 
diff --git a/hw/display/omap_dss.c b/hw/display/omap_dss.c
16
 
index 2c74384..4ef34c0 100644
17
 
--- a/hw/display/omap_dss.c
18
 
+++ b/hw/display/omap_dss.c
19
 
@@ -2332,6 +2332,11 @@ static void omap_dsi_write(void *opaque, hwaddr addr,
20
 
         TRACEDSI("DSI_COMPLEXIO_CFG_2 = 0x%08x", value);
21
 
         s->dsi.complexio_cfg2 = (value & 0xfffcffff)
22
 
                                 | (s->dsi.complexio_cfg2 & (3 << 16));
23
 
+        if (((value >> 5) & 3)) {
24
 
+            s->dsi.complexio_irqst |= (1 << 30); /* ULPSACTIVENOT_ALL0_IRQ */
25
 
+            s->dsi.irqst |= (1 << 10);           /* COMPLEXIO_ERR_IRQ */
26
 
+            omap_dss_interrupt_update(s);
27
 
+        }
28
 
         break;
29
 
     case 0x080: /* DSI_VM_TIMING4 */
30
 
         TRACEDSI("DSI_VM_TIMING4 = 0x%08x", value);
31
 
1.8.5.2
32