~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0059-Add-Cortex-A8-r2-support.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-04 12:13:08 UTC
  • mfrom: (10.1.45 sid)
  • Revision ID: package-import@ubuntu.com-20140204121308-1xq92lrfs75agw2g
Tags: 1.7.0+dfsg-3ubuntu1~ppa1
* Merge 1.7.0+dfsg-3 from debian.  Remaining changes:
  - debian/patches/ubuntu:
    * expose-vmx_qemu64cpu.patch
    * linaro (omap3) and arm64 patches
    * ubuntu/target-ppc-add-stubs-for-kvm-breakpoints: fix FTBFS
      on ppc
    * ubuntu/CVE-2013-4377.patch: fix denial of service via virtio
  - debian/qemu-system-x86.modprobe: set kvm_intel nested=1 options
  - debian/control:
    * add arm64 to Architectures
    * add qemu-common and qemu-system-aarch64 packages
  - debian/qemu-system-common.install: add debian/tmp/usr/lib
  - debian/qemu-system-common.preinst: add kvm group
  - debian/qemu-system-common.postinst: remove acl placed by udev,
    and add udevadm trigger.
  - qemu-system-x86.links: add eepro100.rom, remove pxe-virtio,
    pxe-e1000 and pxe-rtl8139.
  - add qemu-system-x86.qemu-kvm.upstart and .default
  - qemu-user-static.postinst-in: remove arm64 binfmt
  - debian/rules:
    * allow parallel build
    * add aarch64 to system_targets and sys_systems
    * add qemu-kvm-spice links
    * install qemu-system-x86.modprobe
  - add debian/qemu-system-common.links for OVMF.fd link
* Remove kvm-img, kvm-nbd, kvm-ifup and kvm-ifdown symlinks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 3c164ca61b304200f0acbcf53826a46bb1c04da0 Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:33 +0000
 
4
Subject: [PATCH 59/70] Add Cortex A8 r2 support
 
5
 
 
6
---
 
7
 target-arm/cpu.c | 41 +++++++++++++++++++++++++++++++++++++++++
 
8
 1 file changed, 41 insertions(+)
 
9
 
 
10
diff --git a/target-arm/cpu.c b/target-arm/cpu.c
 
11
index e46fc4a..3dd5b02 100644
 
12
--- a/target-arm/cpu.c
 
13
+++ b/target-arm/cpu.c
 
14
@@ -550,6 +550,46 @@ static void cortex_a8_initfn(Object *obj)
 
15
     define_arm_cp_regs(cpu, cortexa8_cp_reginfo);
 
16
 }
 
17
 
 
18
+static void cortex_a8_r2_initfn(Object *obj)
 
19
+{
 
20
+    /* TODO:
 
21
+     * 1. do we really need this?
 
22
+     * 2. are these register values all correct? mostly same as A8 currently
 
23
+     */
 
24
+    ARMCPU *cpu = ARM_CPU(obj);
 
25
+    set_feature(&cpu->env, ARM_FEATURE_V7);
 
26
+    set_feature(&cpu->env, ARM_FEATURE_VFP3);
 
27
+    set_feature(&cpu->env, ARM_FEATURE_NEON);
 
28
+    set_feature(&cpu->env, ARM_FEATURE_THUMB2EE);
 
29
+    set_feature(&cpu->env, ARM_FEATURE_DUMMY_C15_REGS);
 
30
+    set_feature(&cpu->env, ARM_FEATURE_TRUSTZONE);
 
31
+    cpu->midr = 0x410fc083;
 
32
+    cpu->reset_fpsid = 0x410330c2;
 
33
+    cpu->mvfr0 = 0x11110222;
 
34
+    cpu->mvfr1 = 0x00011111;
 
35
+    cpu->ctr = 0x82048004;
 
36
+    cpu->reset_sctlr = 0x00c50078;
 
37
+    cpu->id_pfr0 = 0x1031;
 
38
+    cpu->id_pfr1 = 0x11;
 
39
+    cpu->id_dfr0 = 0x400;
 
40
+    cpu->id_afr0 = 0;
 
41
+    cpu->id_mmfr0 = 0x31100003;
 
42
+    cpu->id_mmfr1 = 0x20000000;
 
43
+    cpu->id_mmfr2 = 0x01202000;
 
44
+    cpu->id_mmfr3 = 0x11;
 
45
+    cpu->id_isar0 = 0x00101111;
 
46
+    cpu->id_isar1 = 0x12112111;
 
47
+    cpu->id_isar2 = 0x21232031;
 
48
+    cpu->id_isar3 = 0x11112131;
 
49
+    cpu->id_isar4 = 0x00111142;
 
50
+    cpu->clidr = (1 << 27) | (2 << 24) | 3;
 
51
+    cpu->ccsidr[0] = 0xe007e01a; /* 16k L1 dcache. */
 
52
+    cpu->ccsidr[1] = 0x2007e01a; /* 16k L1 icache. */
 
53
+    cpu->ccsidr[2] = 0xf03fe03a; /* 256k L2 cache. */
 
54
+    cpu->reset_auxcr = 2;
 
55
+    define_arm_cp_regs(cpu, cortexa8_cp_reginfo);
 
56
+}
 
57
+
 
58
 static const ARMCPRegInfo cortexa9_cp_reginfo[] = {
 
59
     /* power_control should be set to maximum latency. Again,
 
60
      * default to 0 and set by private hook
 
61
@@ -874,6 +914,7 @@ static const ARMCPUInfo arm_cpus[] = {
 
62
     { .name = "cortex-m3",   .initfn = cortex_m3_initfn,
 
63
                              .class_init = arm_v7m_class_init },
 
64
     { .name = "cortex-a8",   .initfn = cortex_a8_initfn },
 
65
+    { .name = "cortex-a8-r2",.initfn = cortex_a8_r2_initfn },
 
66
     { .name = "cortex-a9",   .initfn = cortex_a9_initfn },
 
67
     { .name = "cortex-a15",  .initfn = cortex_a15_initfn },
 
68
     { .name = "ti925t",      .initfn = ti925t_initfn },
 
69
-- 
 
70
1.8.5.2
 
71