~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches-1.5.0/0020-omap_i2c-add-vmstate.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From a0d8a52ecf9cf13759854232834fe5ea17e6fe5f Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:26 +0000
4
 
Subject: [PATCH 20/69] omap_i2c: add vmstate
5
 
 
6
 
XXX shouldn't be using vmstate_register
7
 
---
8
 
 hw/i2c/omap_i2c.c | 35 +++++++++++++++++++++++++++++++++++
9
 
 1 file changed, 35 insertions(+)
10
 
 
11
 
diff --git a/hw/i2c/omap_i2c.c b/hw/i2c/omap_i2c.c
12
 
index 946ccdf..d15e558 100644
13
 
--- a/hw/i2c/omap_i2c.c
14
 
+++ b/hw/i2c/omap_i2c.c
15
 
@@ -568,6 +568,40 @@ static const MemoryRegionOps omap_i2c_ops = {
16
 
     .endianness = DEVICE_NATIVE_ENDIAN,
17
 
 };
18
 
 
19
 
+static int omap_i2c_bus_post_load(void *opaque, int version_id)
20
 
+{
21
 
+    OMAPI2CState *s = opaque;
22
 
+    omap_i2c_interrupts_update(s);
23
 
+    return 0;
24
 
+}
25
 
+
26
 
+static const VMStateDescription vmstate_omap_i2c = {
27
 
+    .name = "omap_i2c",
28
 
+    .version_id = 1,
29
 
+    .minimum_version_id = 1,
30
 
+    .post_load = omap_i2c_bus_post_load,
31
 
+    .fields = (VMStateField[]) {
32
 
+        VMSTATE_UINT16(mask, OMAPI2CState),
33
 
+        VMSTATE_UINT16(stat, OMAPI2CState),
34
 
+        VMSTATE_UINT16(we, OMAPI2CState),
35
 
+        VMSTATE_UINT16(dma, OMAPI2CState),
36
 
+        VMSTATE_UINT16(count, OMAPI2CState),
37
 
+        VMSTATE_INT32(count_cur, OMAPI2CState),
38
 
+        VMSTATE_UINT16(sysc, OMAPI2CState),
39
 
+        VMSTATE_UINT16(control, OMAPI2CState),
40
 
+        VMSTATE_UINT16_ARRAY(own_addr, OMAPI2CState, 4),
41
 
+        VMSTATE_UINT16(slave_addr, OMAPI2CState),
42
 
+        VMSTATE_UINT8(sblock, OMAPI2CState),
43
 
+        VMSTATE_UINT8(divider, OMAPI2CState),
44
 
+        VMSTATE_UINT16_ARRAY(times, OMAPI2CState, 2),
45
 
+        VMSTATE_UINT16(test, OMAPI2CState),
46
 
+        VMSTATE_INT32(fifostart, OMAPI2CState),
47
 
+        VMSTATE_INT32(fifolen, OMAPI2CState),
48
 
+        VMSTATE_UINT8_ARRAY(fifo, OMAPI2CState, I2C_MAX_FIFO_SIZE),
49
 
+        VMSTATE_END_OF_LIST()
50
 
+    }
51
 
+};
52
 
+
53
 
 static int omap_i2c_init(SysBusDevice *dev)
54
 
 {
55
 
     OMAPI2CState *s = FROM_SYSBUS(OMAPI2CState, dev);
56
 
@@ -604,6 +638,7 @@ static void omap_i2c_class_init(ObjectClass *klass, void *data)
57
 
     k->init = omap_i2c_init;
58
 
     dc->props = omap_i2c_properties;
59
 
     dc->reset = omap_i2c_reset;
60
 
+    dc->vmsd = &vmstate_omap_i2c;
61
 
 }
62
 
 
63
 
 static const TypeInfo omap_i2c_info = {
64
 
1.8.1.2
65