~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/use-fixed-data-path.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
19
19
While at it, also increase max number of data path elements
20
20
from 16 to 32.
21
21
 
22
 
Index: qemu/os-posix.c
23
 
===================================================================
24
 
--- qemu.orig/os-posix.c        2013-05-22 19:56:19.673313513 +0200
25
 
+++ qemu/os-posix.c     2013-05-22 19:56:43.849191726 +0200
26
 
@@ -79,6 +79,7 @@
 
22
diff --git a/os-posix.c b/os-posix.c
 
23
index d39261d..ab6b9fd 100644
 
24
--- a/os-posix.c
 
25
+++ b/os-posix.c
 
26
@@ -79,6 +79,7 @@ void os_setup_signal_handling(void)
27
27
     sigaction(SIGTERM, &act, NULL);
28
28
 }
29
29
 
31
31
 /* Find a likely location for support files using the location of the binary.
32
32
    For installed binaries this will be "$bindir/../share/qemu".  When
33
33
    running from the build tree this will be "$bindir/../pc-bios".  */
34
 
@@ -141,6 +142,7 @@
 
34
@@ -141,6 +142,7 @@ char *os_find_datadir(const char *argv0)
35
35
 }
36
36
 #undef SHARE_SUFFIX
37
37
 #undef BUILD_SUFFIX
39
39
 
40
40
 void os_set_proc_name(const char *s)
41
41
 {
42
 
Index: qemu/vl.c
43
 
===================================================================
44
 
--- qemu.orig/vl.c      2013-05-22 19:56:43.625192855 +0200
45
 
+++ qemu/vl.c   2013-05-22 19:56:43.849191726 +0200
46
 
@@ -179,7 +179,10 @@
 
42
diff --git a/vl.c b/vl.c
 
43
index 25b8f2f..1b14f39 100644
 
44
--- a/vl.c
 
45
+++ b/vl.c
 
46
@@ -179,7 +179,10 @@ int main(int argc, char **argv)
47
47
 #define MAX_VIRTIO_CONSOLES 1
48
48
 #define MAX_SCLP_CONSOLES 1
49
49
 
55
55
 static int data_dir_idx;
56
56
 const char *bios_name = NULL;
57
57
 enum vga_retrace_method vga_retrace_method = VGA_RETRACE_DUMB;
58
 
@@ -3960,18 +3963,19 @@
 
58
@@ -3939,18 +3942,19 @@ int main(int argc, char **argv, char **envp)
59
59
         exit(1);
60
60
     }
61
61
 
81
81
     }
82
82
+#endif
83
83
 
84
 
     /*
85
 
      * Default to max_cpus = smp_cpus, in case the user doesn't
 
84
     smp_parse(qemu_opts_find(qemu_find_opts("smp-opts"), NULL));
 
85