~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches/0017-omap_i2c-clean-up-revision-numbers.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From a97763597ddba93c7bbbe6c247dcd4584f0640f1 Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:26 +0000
 
4
Subject: [PATCH 17/71] omap_i2c: clean up revision numbers
 
5
 
 
6
---
 
7
 hw/i2c/omap_i2c.c | 9 ++++++---
 
8
 1 file changed, 6 insertions(+), 3 deletions(-)
 
9
 
 
10
diff --git a/hw/i2c/omap_i2c.c b/hw/i2c/omap_i2c.c
 
11
index f528b2b..7d47dc7 100644
 
12
--- a/hw/i2c/omap_i2c.c
 
13
+++ b/hw/i2c/omap_i2c.c
 
14
@@ -51,8 +51,11 @@ typedef struct OMAPI2CState {
 
15
     uint16_t test;
 
16
 } OMAPI2CState;
 
17
 
 
18
-#define OMAP2_INTR_REV 0x34
 
19
-#define OMAP2_GC_REV   0x34
 
20
+/* I2C controller revision register values */
 
21
+#define OMAP1_INTR_REV    0x11
 
22
+#define OMAP2_INTR_REV    0x34
 
23
+#define OMAP3_INTR_REV    0x3c
 
24
+#define OMAP3630_INTR_REV 0x40
 
25
 
 
26
 static void omap_i2c_interrupts_update(OMAPI2CState *s)
 
27
 {
 
28
@@ -266,7 +269,7 @@ static void omap_i2c_write(void *opaque, hwaddr addr,
 
29
         return;
 
30
 
 
31
     case 0x04: /* I2C_IE */
 
32
-        s->mask = value & (s->revision < OMAP2_GC_REV ? 0x1f : 0x3f);
 
33
+        s->mask = value & (s->revision < OMAP2_INTR_REV ? 0x1f : 0x3f);
 
34
         break;
 
35
 
 
36
     case 0x08: /* I2C_STAT */
 
37
-- 
 
38
1.8.3.2
 
39