~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches/0063-hw-omap_intc.c-Don-t-complain-about-nonexistent-regi.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From ac7230772a160f172a107cb21a22b016ec36fc24 Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:34 +0000
 
4
Subject: [PATCH 63/71] hw/omap_intc.c: Don't complain about nonexistent
 
5
 register read by Linux
 
6
 
 
7
The Linux omap kernel now deliberately reads from the nonexistent register
 
8
at 0xf8, which only exists on ti816x, because it knows that on omap2 and
 
9
omap3 this will read as zero. Handle it that way (ie suppress qemu's
 
10
complaint about read of a bad register), since otherwise the omap3
 
11
model has so many warnings it is unusable.
 
12
 
 
13
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
14
---
 
15
 hw/intc/omap_intc.c | 6 +++++-
 
16
 1 file changed, 5 insertions(+), 1 deletion(-)
 
17
 
 
18
diff --git a/hw/intc/omap_intc.c b/hw/intc/omap_intc.c
 
19
index 7dd63da..6cbb259 100644
 
20
--- a/hw/intc/omap_intc.c
 
21
+++ b/hw/intc/omap_intc.c
 
22
@@ -414,7 +414,11 @@ static uint64_t omap2_inth_read(void *opaque, hwaddr addr,
 
23
             offset &= ~0x60;
 
24
             bank = &s->bank[bank_no];
 
25
         } else {
 
26
-            OMAP_BAD_REG(addr);
 
27
+            /* Linux reads the nonexistent interrupt status register at 0xf8
 
28
+             * every time through its interrupt handler, so don't actually
 
29
+             * warn about it because it swamps the console with output.
 
30
+             */
 
31
+            /* OMAP_BAD_REG(addr); */
 
32
             return 0;
 
33
         }
 
34
     }
 
35
-- 
 
36
1.8.3.2
 
37