~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches/0033-hw-omap_uart.c-omap_uart_attach-add-label-argument.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 2683e338ab8c58065cd4363211e79c4954fa9772 Mon Sep 17 00:00:00 2001
 
2
From: Riku Voipio <riku.voipio@nokia.com>
 
3
Date: Mon, 18 Feb 2013 16:58:29 +0000
 
4
Subject: [PATCH 33/71] hw/omap_uart.c omap_uart_attach: add label argument
 
5
 
 
6
Add label argument to omap_uart_attach
 
7
---
 
8
 hw/arm/nseries.c      | 2 +-
 
9
 hw/char/omap_uart.c   | 5 +++--
 
10
 include/hw/arm/omap.h | 3 ++-
 
11
 3 files changed, 6 insertions(+), 4 deletions(-)
 
12
 
 
13
diff --git a/hw/arm/nseries.c b/hw/arm/nseries.c
 
14
index f4218f0..2a079a2 100644
 
15
--- a/hw/arm/nseries.c
 
16
+++ b/hw/arm/nseries.c
 
17
@@ -786,7 +786,7 @@ static void n8x0_uart_setup(struct n800_s *s)
 
18
     qdev_connect_gpio_out(s->mpu->gpio, N8X0_BT_WKUP_GPIO,
 
19
                     csrhci_pins_get(radio)[csrhci_pin_wakeup]);
 
20
 
 
21
-    omap_uart_attach(s->mpu->uart[BT_UART], radio);
 
22
+    omap_uart_attach(s->mpu->uart[BT_UART], radio, "bt-uart");
 
23
 }
 
24
 
 
25
 static void n8x0_usb_setup(struct n800_s *s)
 
26
diff --git a/hw/char/omap_uart.c b/hw/char/omap_uart.c
 
27
index 0b91693..61d893b 100644
 
28
--- a/hw/char/omap_uart.c
 
29
+++ b/hw/char/omap_uart.c
 
30
@@ -177,11 +177,12 @@ struct omap_uart_s *omap2_uart_init(MemoryRegion *sysmem,
 
31
     return s;
 
32
 }
 
33
 
 
34
-void omap_uart_attach(struct omap_uart_s *s, CharDriverState *chr)
 
35
+void omap_uart_attach(struct omap_uart_s *s, CharDriverState *chr,
 
36
+                      const char *label)
 
37
 {
 
38
     /* TODO: Should reuse or destroy current s->serial */
 
39
     s->serial = serial_mm_init(get_system_memory(), s->base, 2, s->irq,
 
40
                                omap_clk_getrate(s->fclk) / 16,
 
41
-                               chr ?: qemu_chr_new("null", "null", NULL),
 
42
+                               chr ?: qemu_chr_new(label, "null", NULL),
 
43
                                DEVICE_NATIVE_ENDIAN);
 
44
 }
 
45
diff --git a/include/hw/arm/omap.h b/include/hw/arm/omap.h
 
46
index 21d83a6..e408771 100644
 
47
--- a/include/hw/arm/omap.h
 
48
+++ b/include/hw/arm/omap.h
 
49
@@ -882,7 +882,8 @@ struct omap_uart_s *omap2_uart_init(MemoryRegion *sysmem,
 
50
                 qemu_irq txdma, qemu_irq rxdma,
 
51
                 const char *label, CharDriverState *chr);
 
52
 void omap_uart_reset(struct omap_uart_s *s);
 
53
-void omap_uart_attach(struct omap_uart_s *s, CharDriverState *chr);
 
54
+void omap_uart_attach(struct omap_uart_s *s, CharDriverState *chr,
 
55
+                      const char *label);
 
56
 
 
57
 struct omap_mpuio_s;
 
58
 qemu_irq *omap_mpuio_in_get(struct omap_mpuio_s *s);
 
59
-- 
 
60
1.8.3.2
 
61