~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 58ee9b0ae05d81c74d6869a25ce4263fc22ed809 Mon Sep 17 00:00:00 2001
2
 
From: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
3
 
Date: Mon, 3 Jun 2013 15:38:31 +0000
4
 
Subject: [PATCH] xen_machine_pv: do not create a dummy CPU in machine->init
5
 
MIME-Version: 1.0
6
 
Content-Type: text/plain; charset=UTF-8
7
 
Content-Transfer-Encoding: 8bit
8
 
 
9
 
This fixes a regression introduced by:
10
 
 
11
 
commit 62fc403f11523169eb4264de31279745f48e3ecc
12
 
Author: Igor Mammedov <imammedo@redhat.com>
13
 
Date:   Mon Apr 29 18:54:13 2013 +0200
14
 
 
15
 
    target-i386: Attach ICC bus to CPU on its creation
16
 
 
17
 
    X86CPU should have parent bus so it could provide bus for child APIC.
18
 
 
19
 
The commit makes it mandatory to pass a valid ICC bus to cpu_x86_create,
20
 
but cpu_x86_init just passes NULL to it.
21
 
xen_machine_pv uses cpu_x86_init, therefore it has been broken.
22
 
 
23
 
This patch fixes the problem by removing the dummy CPU creation
24
 
altogether from xen_init_pv, relying on the fact that QEMU can now cope
25
 
with a machine without an emulated CPU.
26
 
 
27
 
Signed-off-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
28
 
Reviewed-by: Andreas Färber <afaerber@suse.de>
29
 
CC: imammedo@redhat.com
30
 
CC: qemu-stable@nongnu.org
31
 
---
32
 
 hw/i386/xen_machine_pv.c |   16 ----------------
33
 
 1 file changed, 16 deletions(-)
34
 
 
35
 
diff --git a/hw/i386/xen_machine_pv.c b/hw/i386/xen_machine_pv.c
36
 
index f829a52..9f2e291 100644
37
 
--- a/hw/i386/xen_machine_pv.c
38
 
+++ b/hw/i386/xen_machine_pv.c
39
 
@@ -23,7 +23,6 @@
40
 
  */
41
 
 
42
 
 #include "hw/hw.h"
43
 
-#include "hw/i386/pc.h"
44
 
 #include "hw/boards.h"
45
 
 #include "hw/xen/xen_backend.h"
46
 
 #include "xen_domainbuild.h"
47
 
@@ -31,27 +30,12 @@
48
 
 
49
 
 static void xen_init_pv(QEMUMachineInitArgs *args)
50
 
 {
51
 
-    const char *cpu_model = args->cpu_model;
52
 
     const char *kernel_filename = args->kernel_filename;
53
 
     const char *kernel_cmdline = args->kernel_cmdline;
54
 
     const char *initrd_filename = args->initrd_filename;
55
 
-    X86CPU *cpu;
56
 
-    CPUState *cs;
57
 
     DriveInfo *dinfo;
58
 
     int i;
59
 
 
60
 
-    /* Initialize a dummy CPU */
61
 
-    if (cpu_model == NULL) {
62
 
-#ifdef TARGET_X86_64
63
 
-        cpu_model = "qemu64";
64
 
-#else
65
 
-        cpu_model = "qemu32";
66
 
-#endif
67
 
-    }
68
 
-    cpu = cpu_x86_init(cpu_model);
69
 
-    cs = CPU(cpu);
70
 
-    cs->halted = 1;
71
 
-
72
 
     /* Initialize backend core & drivers */
73
 
     if (xen_be_init() != 0) {
74
 
         fprintf(stderr, "%s: xen backend core setup failed\n", __FUNCTION__);
75
 
1.7.9.5
76