~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches/0040-fifo8-Add-support-for-reading-number-of-bytes-in-FIF.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From dead0a2696388c3a3d6f755f52132c8bdd041ccb Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 5 Aug 2013 16:13:01 +0100
 
4
Subject: [PATCH 40/71] fifo8: Add support for reading number of bytes in FIFO
 
5
 
 
6
Add a fifo8_num() function which returns the number
 
7
of bytes currently in the FIFO.
 
8
 
 
9
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
10
---
 
11
 include/qemu/fifo8.h | 10 ++++++++++
 
12
 util/fifo8.c         |  5 +++++
 
13
 2 files changed, 15 insertions(+)
 
14
 
 
15
diff --git a/include/qemu/fifo8.h b/include/qemu/fifo8.h
 
16
index d318f71..fec175c 100644
 
17
--- a/include/qemu/fifo8.h
 
18
+++ b/include/qemu/fifo8.h
 
19
@@ -86,6 +86,16 @@ bool fifo8_is_empty(Fifo8 *fifo);
 
20
 
 
21
 bool fifo8_is_full(Fifo8 *fifo);
 
22
 
 
23
+/**
 
24
+ * fifo8_num:
 
25
+ * @fifo: FIFO to check
 
26
+ *
 
27
+ * Return the number of bytes of data currently in the FIFO.
 
28
+ *
 
29
+ * Returns: number of bytes of data in FIFO.
 
30
+ */
 
31
+uint32_t fifo8_num(Fifo8 *fifo);
 
32
+
 
33
 extern const VMStateDescription vmstate_fifo8;
 
34
 
 
35
 #define VMSTATE_FIFO8(_field, _state) {                              \
 
36
diff --git a/util/fifo8.c b/util/fifo8.c
 
37
index 013e903..75f0f3b 100644
 
38
--- a/util/fifo8.c
 
39
+++ b/util/fifo8.c
 
40
@@ -65,6 +65,11 @@ bool fifo8_is_full(Fifo8 *fifo)
 
41
     return (fifo->num == fifo->capacity);
 
42
 }
 
43
 
 
44
+uint32_t fifo8_num(Fifo8 *fifo)
 
45
+{
 
46
+    return fifo->num;
 
47
+}
 
48
+
 
49
 const VMStateDescription vmstate_fifo8 = {
 
50
     .name = "Fifo8",
 
51
     .version_id = 1,
 
52
-- 
 
53
1.8.3.2
 
54