~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches/0066-musb-add-dummy-support-for-ulpi-pass-through-registe.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 07b76dab18ba21821d7c428e3a76d7ab4f1b76b4 Mon Sep 17 00:00:00 2001
 
2
From: =?UTF-8?q?Juha=20Riihim=C3=A4ki?= <juha.riihimaki@nokia.com>
 
3
Date: Mon, 18 Feb 2013 16:58:35 +0000
 
4
Subject: [PATCH 66/71] musb: add dummy support for ulpi pass-through registers
 
5
MIME-Version: 1.0
 
6
Content-Type: text/plain; charset=UTF-8
 
7
Content-Transfer-Encoding: 8bit
 
8
 
 
9
Signed-off-by: Juha Riihimäki <juha.riihimaki@nokia.com>
 
10
---
 
11
 hw/usb/hcd-musb.c | 18 ++++++++++++++++++
 
12
 1 file changed, 18 insertions(+)
 
13
 
 
14
diff --git a/hw/usb/hcd-musb.c b/hw/usb/hcd-musb.c
 
15
index 7968e17..a190020 100644
 
16
--- a/hw/usb/hcd-musb.c
 
17
+++ b/hw/usb/hcd-musb.c
 
18
@@ -65,6 +65,7 @@
 
19
 #define MUSB_HDRC_ULPI_REGDATA 0x74
 
20
 #define MUSB_HDRC_ULPI_REGADDR 0x75
 
21
 #define MUSB_HDRC_ULPI_REGCTL  0x76
 
22
+#define MUSB_HDRC_ULPI_RAWDATA  0x77
 
23
 
 
24
 /* Extended config & PHY control */
 
25
 #define MUSB_HDRC_ENDCOUNT     0x78    /* 8 bit */
 
26
@@ -1293,6 +1294,16 @@ static uint32_t musb_readb(void *opaque, hwaddr addr)
 
27
         ep = ((addr - MUSB_HDRC_FIFO) >> 2) & 0xf;
 
28
         return musb_read_fifo(s->ep + ep);
 
29
 
 
30
+    case MUSB_HDRC_ULPI_REGADDR:
 
31
+    case MUSB_HDRC_ULPI_REGDATA:
 
32
+    case MUSB_HDRC_ULPI_RAWDATA:
 
33
+        /* TODO */
 
34
+        return 0x00;
 
35
+
 
36
+    case MUSB_HDRC_ULPI_REGCTL:
 
37
+        /* TODO */
 
38
+        return 0x02;
 
39
+
 
40
     default:
 
41
         TRACE("unknown register 0x%02x", (int) addr);
 
42
         return 0x00;
 
43
@@ -1380,6 +1391,13 @@ static void musb_writeb(void *opaque, hwaddr addr, uint32_t value)
 
44
         musb_write_fifo(s->ep + ep, value & 0xff);
 
45
         break;
 
46
 
 
47
+    case MUSB_HDRC_ULPI_REGADDR:
 
48
+    case MUSB_HDRC_ULPI_REGCTL:
 
49
+    case MUSB_HDRC_ULPI_REGDATA:
 
50
+    case MUSB_HDRC_ULPI_RAWDATA:
 
51
+        /* TODO */
 
52
+        break;
 
53
+
 
54
     default:
 
55
         TRACE("unknown register 0x%02x", (int) addr);
 
56
         break;
 
57
-- 
 
58
1.8.3.2
 
59