~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches-1.5.0/0035-serial-reset-lsr-dr-thre-upon-fcr-rfr-xfr.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 433f879015ea04ca3053b15bf5b834b28badd977 Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:29 +0000
4
 
Subject: [PATCH 35/69] serial: reset lsr dr/thre upon fcr rfr/xfr
5
 
MIME-Version: 1.0
6
 
Content-Type: text/plain; charset=UTF-8
7
 
Content-Transfer-Encoding: 8bit
8
 
 
9
 
Includes:
10
 
 
11
 
further fix serial.c fifo clear
12
 
 
13
 
when receive fifo is requested to be cleared and there is a received byte
14
 
pending to be read, accept the byte while discarding it so it will not stay
15
 
pending.
16
 
 
17
 
yet another serial tweak
18
 
 
19
 
...so needs review!
20
 
 
21
 
Signed-off-by: Juha Riihimäki <juha.riihimaki@nokia.com>
22
 
---
23
 
 hw/char/serial.c | 7 +++++++
24
 
 1 file changed, 7 insertions(+)
25
 
 
26
 
diff --git a/hw/char/serial.c b/hw/char/serial.c
27
 
index 0383972..e5e511b 100644
28
 
--- a/hw/char/serial.c
29
 
+++ b/hw/char/serial.c
30
 
@@ -368,10 +368,17 @@ static void serial_ioport_write(void *opaque, hwaddr addr, uint64_t val,
31
 
             qemu_del_timer(s->fifo_timeout_timer);
32
 
             s->timeout_ipending=0;
33
 
             fifo_clear(s,RECV_FIFO);
34
 
+            if ((s->lsr & UART_LSR_DR)) {
35
 
+                s->lsr &= ~(UART_LSR_DR | UART_LSR_BI | UART_LSR_OE);
36
 
+                if (!(s->mcr & UART_MCR_LOOP)) {
37
 
+                    qemu_chr_accept_input(s->chr);
38
 
+                }
39
 
+            }
40
 
         }
41
 
 
42
 
         if (val & UART_FCR_XFR) {
43
 
             fifo_clear(s,XMIT_FIFO);
44
 
+            s->lsr |= UART_LSR_THRE;
45
 
         }
46
 
 
47
 
         if (val & UART_FCR_FE) {
48
 
1.8.1.2
49