~ubuntu-branches/ubuntu/trusty/qemu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches-1.5.0/0038-hw-omap_uart.c-Forbid-extended-MCR-bit-writes-unless.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-10-22 22:47:07 UTC
  • mfrom: (1.8.3) (10.1.42 sid)
  • Revision ID: package-import@ubuntu.com-20131022224707-1lya34fw3k3f24tv
Tags: 1.6.0+dfsg-2ubuntu1
* Merge 1.6.0~rc0+dfsg-2exp from debian experimental.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
      - drop openbios-ppc and openhackware Depends to Suggests (for now)
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - New linaro patches from qemu-linaro rebasing branch
  - Dropped patches:
    * xen-simplify-xen_enabled.patch
    * sparc-linux-user-fix-missing-symbols-in-.rel-.rela.plt-sections.patch
    * main_loop-do-not-set-nonblocking-if-xen_enabled.patch
    * xen_machine_pv-do-not-create-a-dummy-CPU-in-machine-.patch
    * virtio-rng-fix-crash
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * linaro arm patches from qemu-linaro rebasing branch
  - New patches:
    * fix-pci-add: change CONFIG variable in ifdef to make sure that
      pci_add is defined.
* Add linaro patches
* Add experimental mach-virt patches for arm virtualization.
* qemu-system-common.install: add debian/tmp/usr/lib to install the
  qemu-bridge-helper

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 5fadc5e5df2666f56982295bb875783bc9fe6e14 Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:29 +0000
4
 
Subject: [PATCH 38/69] hw/omap_uart.c: Forbid extended MCR bit writes unless
5
 
 in enhanced mode
6
 
 
7
 
The OMAP UART defines new functions for MCR bits 5 and 6;
8
 
these can only be written if the appropriate bit is set in the
9
 
EFR register.
10
 
 
11
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
12
 
---
13
 
 hw/char/omap_uart.c | 13 ++++++++++---
14
 
 1 file changed, 10 insertions(+), 3 deletions(-)
15
 
 
16
 
diff --git a/hw/char/omap_uart.c b/hw/char/omap_uart.c
17
 
index eb1d6fc..d5f7bb8 100644
18
 
--- a/hw/char/omap_uart.c
19
 
+++ b/hw/char/omap_uart.c
20
 
@@ -121,8 +121,10 @@ static uint64_t omap_uart_read(void *opaque, hwaddr addr,
21
 
         if (s->access_mode == regs_config_b) {
22
 
             return s->xon[(addr & 7) >> 2];
23
 
         } else if (addr == 0x10) {
24
 
-            return s->serial_ops->read(s->serial, addr, size)
25
 
-                   | (s->mcr_cache & 0xe0);
26
 
+            /* MCR. Bits 5 and 6 are handled by us, the rest by
27
 
+             * the underlying serial implementation.
28
 
+             */
29
 
+            return s->serial_ops->read(s->serial, addr, size) | s->mcr_cache;
30
 
         }
31
 
         return s->serial_ops->read(s->serial, addr, size);
32
 
     case 0x18:
33
 
@@ -210,7 +212,12 @@ static void omap_uart_write(void *opaque, hwaddr addr,
34
 
             s->xon[(addr & 7) >> 2] = value;
35
 
         } else {
36
 
             if (addr == 0x10) {
37
 
-                s->mcr_cache = value & 0x7f;
38
 
+                /* Bits 5 and 6 are handled at this level; they can
39
 
+                 * only be written if EFR_REG:ENHANCED_EN is set.
40
 
+                 */
41
 
+                if (s->efr & 0x10) {
42
 
+                    s->mcr_cache = value & 0x60;
43
 
+                }
44
 
             }
45
 
             s->serial_ops->write(s->serial, addr, value, size);
46
 
         }
47
 
1.8.1.2
48