~ubuntu-branches/ubuntu/jaunty/gimp/jaunty-security

« back to all changes in this revision

Viewing changes to debian/patches/04_composite-signedness.patch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Holbach
  • Date: 2007-05-02 16:33:03 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20070502163303-bvzhjzbpw8qglc4y
Tags: 2.3.16-1ubuntu1
* Resynchronized with Debian, remaining Ubuntu changes:
  - debian/rules: i18n magic.
* debian/control.in:
  - Maintainer: Ubuntu Core Developers <ubuntu-devel@lists.ubuntu.com>
* debian/patches/02_help-message.patch,
  debian/patches/03_gimp.desktop.in.in.patch,
  debian/patches/10_dont_show_wizard.patch: updated.
* debian/patches/04_composite-signedness.patch,
  debian/patches/05_add-letter-spacing.patch: dropped, used upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- gimp-2.2.11.orig/app/composite/gimp-composite-generic.c
2
 
+++ gimp-2.2.11/app/composite/gimp-composite-generic.c
3
 
@@ -88,8 +88,8 @@
4
 
 {
5
 
   int i;
6
 
   int j;
7
 
-  char *D = ctx->D;
8
 
-  char *A = ctx->A;
9
 
+  unsigned char *D = ctx->D;
10
 
+  unsigned char *A = ctx->A;
11
 
   int bpp_A = gimp_composite_pixel_bpp[ctx->pixelformat_A];
12
 
   int bpp_D = gimp_composite_pixel_bpp[ctx->pixelformat_D];
13
 
 
14
 
@@ -374,8 +374,8 @@
15
 
   guint bytes2 = gimp_composite_pixel_bpp[ctx->pixelformat_B];
16
 
   const guint has_alpha1 = HAS_ALPHA(bytes1);
17
 
   const guint has_alpha2 = HAS_ALPHA(bytes2);
18
 
-  guint r1, g1, b1;
19
 
-  guint r2, g2, b2;
20
 
+  gint r1, g1, b1;
21
 
+  gint r2, g2, b2;
22
 
 
23
 
   if (bytes1 > 2)
24
 
     {
25
 
@@ -442,8 +442,8 @@
26
 
   guint bytes2 = gimp_composite_pixel_bpp[ctx->pixelformat_B];
27
 
   const guint has_alpha1 = HAS_ALPHA(bytes1);
28
 
   const guint has_alpha2 = HAS_ALPHA(bytes2);
29
 
-  guint r1, g1, b1;
30
 
-  guint r2, g2, b2;
31
 
+  gint r1, g1, b1;
32
 
+  gint r2, g2, b2;
33
 
 
34
 
   if (bytes1 > 2) {
35
 
     /*  assumes inputs are only 4 byte RGBA pixels  */
36
 
@@ -501,8 +501,8 @@
37
 
   guint bytes2 = gimp_composite_pixel_bpp[ctx->pixelformat_B];
38
 
   const guint has_alpha1 = HAS_ALPHA(bytes1);
39
 
   const guint has_alpha2 = HAS_ALPHA(bytes2);
40
 
-  guint r1, g1, b1;
41
 
-  guint r2, g2, b2;
42
 
+  gint r1, g1, b1;
43
 
+  gint r2, g2, b2;
44
 
 
45
 
   if (bytes1 > 2) {
46
 
     /*  assumes inputs are only 4 byte RGBA pixels  */
47
 
@@ -561,8 +561,8 @@
48
 
   guint bytes2 = gimp_composite_pixel_bpp[ctx->pixelformat_B];
49
 
   const guint has_alpha1 = HAS_ALPHA(bytes1);
50
 
   const guint has_alpha2 = HAS_ALPHA(bytes2);
51
 
-  guint r1, g1, b1;
52
 
-  guint r2, g2, b2;
53
 
+  gint r1, g1, b1;
54
 
+  gint r2, g2, b2;
55
 
 
56
 
   if (bytes1 > 2) {
57
 
     /*  assumes inputs are only 4 byte RGBA pixels  */