~ubuntu-branches/ubuntu/jaunty/gimp/jaunty-security

« back to all changes in this revision

Viewing changes to debian/patches/10_dont_show_wizard.patch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Holbach
  • Date: 2007-05-02 16:33:03 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20070502163303-bvzhjzbpw8qglc4y
Tags: 2.3.16-1ubuntu1
* Resynchronized with Debian, remaining Ubuntu changes:
  - debian/rules: i18n magic.
* debian/control.in:
  - Maintainer: Ubuntu Core Developers <ubuntu-devel@lists.ubuntu.com>
* debian/patches/02_help-message.patch,
  debian/patches/03_gimp.desktop.in.in.patch,
  debian/patches/10_dont_show_wizard.patch: updated.
* debian/patches/04_composite-signedness.patch,
  debian/patches/05_add-letter-spacing.patch: dropped, used upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur gimp-2.2.11/app/dialogs/user-install-dialog.c gimp-2.2.11.new/app/dialogs/user-install-dialog.c
2
 
--- gimp-2.2.11/app/dialogs/user-install-dialog.c       2005-02-21 14:15:04.000000000 +0100
3
 
+++ gimp-2.2.11.new/app/dialogs/user-install-dialog.c   2006-07-10 13:34:53.000000000 +0200
4
 
@@ -94,21 +94,22 @@
5
 
 
6
 
 static GtkWidget  *notebook        = NULL;
7
 
 
8
 
+#if USER_INSTALLATION_DIALOG
9
 
 static GtkWidget  *title_image     = NULL;
10
 
-
11
 
-static GtkWidget  *title_label     = NULL;
12
 
-static GtkWidget  *footer_label    = NULL;
13
 
-
14
 
 static GtkWidget  *log_page        = NULL;
15
 
+#endif
16
 
 static GtkWidget  *tuning_page     = NULL;
17
 
+static GtkWidget  *footer_label    = NULL;
18
 
+static GtkWidget  *title_label     = NULL;
19
 
 
20
 
-static GtkRcStyle *title_style     = NULL;
21
 
-static GtkRcStyle *page_style      = NULL;
22
 
 
23
 
+static GtkRcStyle *page_style      = NULL;
24
 
+static GtkRcStyle *title_style     = NULL;
25
 
+#if USER_INSTALLATION_DIALOG
26
 
 static GdkColor    black_color;
27
 
 static GdkColor    white_color;
28
 
 static GdkColor    title_color;
29
 
-
30
 
+#endif
31
 
 static gchar      *oldgimp         = NULL;
32
 
 static gboolean    migrate         = FALSE;
33
 
 
34
 
@@ -573,6 +574,7 @@
35
 
                          gboolean     verbose)
 
1
diff -Nur gimp-2.3.16/app/dialogs/user-install-dialog.c gimp-2.3.16.new/app/dialogs/user-install-dialog.c
 
2
--- gimp-2.3.16/app/dialogs/user-install-dialog.c       2007-01-23 11:13:50.000000000 +0100
 
3
+++ gimp-2.3.16.new/app/dialogs/user-install-dialog.c   2007-05-02 17:54:23.000000000 +0200
 
4
@@ -46,15 +46,18 @@
 
5
 gboolean
 
6
 user_install_dialog_run (GimpUserInstall *install)
36
7
 {
37
 
   GimpRc    *gimprc;
38
8
+#if USER_INSTALLATION_DIALOG
39
9
   GtkWidget *dialog;
40
 
   GtkWidget *vbox;
41
 
   GtkWidget *hbox;
42
 
@@ -584,10 +586,10 @@
43
 
   GtkWidget *eek_box;
44
 
   GdkPixbuf *wilber;
45
 
   gchar     *filename;
46
 
-  gchar     *version;
47
 
   gchar     *title;
48
 
   gint       i;
49
 
-
50
 
+#endif
51
 
+  gchar     *version;
52
 
   oldgimp = g_strdup (gimp_directory ());
53
 
 
54
 
   /*  FIXME  */
55
 
@@ -604,7 +606,7 @@
56
 
     }
57
 
 
58
 
   gimprc = gimp_rc_new (alternate_system_gimprc, alternate_gimprc, verbose);
59
 
-
60
 
+#if USER_INSTALLATION_DIALOG
61
 
   dialog = user_install_dialog =
62
 
     gimp_dialog_new (_("GIMP User Installation"), "gimp-user-installation",
63
 
                      NULL, 0,
64
 
@@ -1013,6 +1015,9 @@
65
 
 
66
 
   g_free (title);
67
 
   g_free (oldgimp);
68
 
+#else
69
 
+  user_install_run(migrate ? oldgimp : NULL);
70
 
+#endif
71
 
 }
72
 
 
73
 
 
74
 
@@ -1024,6 +1029,7 @@
75
 
            GtkTextBuffer *buffer,
76
 
            GError        *error)
77
 
 {
78
 
+#if USER_INSTALLATION_DIALOG
79
 
   GtkTextIter  cursor;
80
 
   GdkPixbuf   *pixbuf;
81
 
 
82
 
@@ -1049,7 +1055,7 @@
83
 
     }
84
 
 
85
 
   gtk_text_buffer_insert (buffer, &cursor, "\n", -1);
86
 
-
87
 
+#endif
88
 
   while (gtk_events_pending ())
89
 
     gtk_main_iteration ();
90
 
 }
91
 
@@ -1065,7 +1071,9 @@
92
 
   msg = g_strdup_printf (_("Copying file '%s' from '%s'..."),
93
 
                          gimp_filename_to_utf8 (dest),
94
 
                          gimp_filename_to_utf8 (source));
95
 
+#if USER_INSTALLATION_DIALOG
96
 
   gtk_text_buffer_insert_at_cursor (log_buffer, msg, -1);
97
 
+#endif
98
 
   g_free (msg);
99
 
 
100
 
   while (gtk_events_pending ())
101
 
@@ -1083,7 +1091,9 @@
102
 
 
103
 
   msg = g_strdup_printf (_("Creating folder '%s'..."),
104
 
                          gimp_filename_to_utf8 (dirname));
105
 
+#if USER_INSTALLATION_DIALOG
106
 
   gtk_text_buffer_insert_at_cursor (log_buffer, msg, -1);
107
 
+#endif
108
 
   g_free (msg);
109
 
 
110
 
   while (gtk_events_pending ())
111
 
@@ -1302,18 +1312,20 @@
112
 
 static gboolean
113
 
 user_install_run (const gchar *oldgimp)
114
 
 {
115
 
+#if USER_INSTALLATION_DIALOG
116
 
   GtkWidget     *scrolled_window;
117
 
+#endif
118
 
   GtkTextBuffer *log_buffer;
119
 
   GtkWidget     *log_view;
120
 
   GError        *error = NULL;
121
 
-
122
 
+#if USER_INSTALLATION_DIALOG
123
 
   scrolled_window = gtk_scrolled_window_new (NULL, NULL);
124
 
   gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (scrolled_window),
125
 
                                   GTK_POLICY_AUTOMATIC,
126
 
                                   GTK_POLICY_AUTOMATIC);
127
 
   gtk_box_pack_start (GTK_BOX (log_page), scrolled_window, TRUE, TRUE, 0);
128
 
   gtk_widget_show (scrolled_window);
129
 
-
130
 
+#endif
131
 
   log_buffer = gtk_text_buffer_new (NULL);
132
 
 
133
 
   gtk_text_buffer_create_tag (log_buffer, "bold",
134
 
@@ -1322,13 +1334,13 @@
135
 
 
136
 
   log_view = gtk_text_view_new_with_buffer (log_buffer);
137
 
   g_object_unref (log_buffer);
138
 
-
139
 
+#if USER_INSTALLATION_DIALOG
140
 
   PAGE_STYLE (log_view);
141
 
   gtk_text_view_set_editable (GTK_TEXT_VIEW (log_view), FALSE);
142
 
 
143
 
   gtk_container_add (GTK_CONTAINER (scrolled_window), log_view);
144
 
   gtk_widget_show (log_view);
145
 
-
146
 
+#endif
147
 
   if (! user_install_mkdir (log_buffer, gimp_directory (), &error))
 
10
+#endif
 
11
   gboolean   success;
 
12
 
 
13
   g_return_val_if_fail (install != NULL, FALSE);
 
14
-
 
15
+#if USER_INSTALLATION_DIALOG
 
16
   dialog = user_install_dialog_new (install);
 
17
-
 
18
+#endif
 
19
   success = gimp_user_install_run (install);
 
20
 
 
21
+#if USER_INSTALLATION_DIALOG
 
22
   if (! success)
148
23
     {
149
 
       print_log (log_view, log_buffer, error);
 
24
       g_signal_connect (dialog, "response",
 
25
@@ -67,6 +70,7 @@
 
26
     }
 
27
 
 
28
   gtk_widget_destroy (dialog);
 
29
+#endif
 
30
 
 
31
   return success;
 
32
 }